[pskmail] Re: problems getting jPSKmail to work

  • From: Pär Crusefalk <per@xxxxxxxxxxxx>
  • To: pskmail@xxxxxxxxxxxxx
  • Date: Sun, 05 Jan 2014 16:03:28 +0100

Hi Jan,

Seems to me that all your issues have a serial port in them.
This error: "get_java_var: invalid file descriptor "
Should be coming from rxtx (serial port handling problem).
Hamlib, rigctl, seems to have issues with the serial port and the hardware ptt is of course serial port dependent. If fldigi is working fine then I suggest that you remove version 2 of jpskmail and use the latest version one client. Just make sure you delete configuration.xml from .pskmail if you decide to switch to version 1.x as it will cause new issues if left.

73, Per
sm0rwo


On 2014-01-04 19:02, Jan Bruggeman wrote:
All,

First of all, my best wishes for the new year. I'm sure all of you have made good wishes and goals for the new year, and so have I.

One of my 2014 goals is to finally get a working jpskmail installation both at home and on board. I have made a dedicated installation at home so this project will not interfere with my other ongoing projects.

What I have so far:
*** system *****************************************************************
radio hardware:
antenna: gap titan dx
tuner: mfj 929
radio: kenwood ts-140s
optional if-10c/rs232 interface for rig controll: http://www.eham.net/reviews/detail/3275 sound-card connector: psk-simpel-interface from http://www.sec-digital.de/

computer:
old medion pc:
LinuxMint mate 1.6.0, kernel 3.10-2-486 (debian based)
882 Mb intern
250 Gb hd
celeron 450 cpu @2.20Ghz

*** software installed ****************************************************
standard mint installation
extra's:
hamlib (libhamlibs-utils)
ntpd
fldigi
jpskmail 2.0.30 (using file jPSKmail-2.0.30-Linux-x86-Install)

*** startup messages *******************************************************
jan@marconi ~/jpskmail $ java -jar ./javapskmail.jar
configuration.xml
Stable Library
=========================================
Native lib Version = RXTX-2.2pre2
Java lib Version = RXTX-2.1-7
WARNING: RXTX Version mismatch
Jar version = RXTX-2.1-7
native lib Version = RXTX-2.2pre2
Fontconfig warning: "/etc/fonts/conf.d/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected
get_java_var: invalid file descriptor
get_java_var: invalid file descriptor
get_java_var: invalid file descriptor
get_java_var: invalid file descriptor
.....

So I am at a point where the jPSKmail program seems to run fine, except for these 'invalid file descriptor' messages that keep popping up, but doesn't seem to be a problem. I experience some other problems:

*** problem 1 ****************************************************************
using rigctl's ts-140s driver (225) produces the following error:

jan@marconi ~/jpskmail $ rigctl -vv -m 225 -r /dev/ttyUSB0
kenwood_transaction: Command is not correctly terminated 'f���'
kenwood_transaction: Command is not correctly terminated 'f��'
kenwood_transaction: Command is not correctly terminated 'f�'
Opened rig model 225, 'TS-140S'

Rig command: f
kenwood_get_freq: unsupported VFO 536870912
get_freq: error = Invalid parameter

Rig command: q

=> this is resolved in fldigi by using ts-440 driver (202), but jpskmail shows weird behavior when I do that. Sometimes it seems to work, sometimes not.

Note that the rig interface is /dev/ttyUSB0 , 4800 baud

*** problem 2 **************************************************************** hardware ptt doesn't work: the rig does not transmit when pushing connect button => hardware ptt selected over /dev/ttyS0, RTS to be activated. (these settings do work in fldigi)

I've allready tried all possible settings (I think), but to no avail. Can anybody give me a hint as to what I might try next ?

thanks on beforehand and keep up the good work !



Other related posts: