[pskmail] Re: mail attachments

  • From: Franco Spinelli <frspin@xxxxxxxxx>
  • To: pskmail@xxxxxxxxxxxxx
  • Date: Sat, 05 Feb 2011 18:04:02 +0100

Hi Rein

Il 02/02/2011 18:32, Franco Spinelli ha scritto:

In Inbox there is complete mail message but attach is not recognized by
Evolution.
Message is shown as:

------------------005050..................
Content-Transfer-Encoding: 7 bit

Test of message

------------------005050..................
Content-Type: Application/zip;
name="ISS_Track.zip"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
filename="ISS_Track.zip"

Then (apparently) the UUencoded attach.

In Inbox file, after usual header lines, there is directly a separator
line ----------0050........

I suppose is missing a

Content-Type: multipart/mixed; boundary="..........."

header line in message

If I manually modify ~/.pskmail/Inbox with missing header Evolution
correctly decode the message.


I have done some other test with my local server.
This is results:

- sending email with attach using jpskmail only

  this work correct, email go to correct destination with correct attach

- sending email with attach using Evolution + jpskmail

  this show an error on my Python prog. I will send you correct version
  if you send me an email address for this (I suppose no attach on mail
  list)

- receiving email with attach

  mail is received, attach is saved in ~/pskmail/Files directory with an
  incorrect name (filename + " at the end)
  there is no multipart info on file saved in Inbox, as in my email of
  2 feb. Server get info from gmail (there is a line in server window
  with "This is a multi-part message in MIME format." but this info is
  not send to client over radio connection
  A second test, with a binary attach, leave an incomplete message in
  Inbox and no file saved in Files directory. I will investigate
  tomorrow for this.

- deleting mail

  when I request a mail delete a message go to server with ~DELETE 11
  and on server window there is a message
  ::Mail  11 deleted...
  but no activity with gmail. And on gmail mail are not deleted.

A last question about mail upload.

I connect DL9YCS, try to send a messages but get a disconnect.
After that I connect to SM0RWO and, when I try to send my email message jpskmail client try to resume the upload with DL9YCS. I need to remove by hand file in Pending directory.

Sometime my server go to PSK500 but the mode change is ignored by Fldigi and jpskmail. There is some config to set for this?

For now is all. I am forced in home for "seasonal" influenza!

Regards

Franco Spinelli
IW2DHW


Other related posts: