[pskmail] Quit cfm

  • From: 9A3LI <9a3li@xxxxxxxxxxx>
  • To: pskmail@xxxxxxxxxxxxx
  • Date: Tue, 03 Nov 2009 15:33:15 +0100

Hello !

For some time we testing PSKmail server on 80m band for local field operation.
So far main problem are propagation and low power TXes, hi.
Server is 9A1CRA, power max 20W and double quad monoband antenna.
Antenna mainly build for local 80m contest operation.
Some old pictures are here:
http://ham2.cc.fer.hr/9a1cbv/

Now we using latest server and client (for XP and Linux) versions.
Testing 500bps last few weeks.
Everyhing is fine when signals are very strong.
But when some weak station connect server or server cant receive "quit"
then it "hangs" somehow.
If some other station try to conenct server it got wierd message from it.
Some logs:

21:47 UTC Nov-2-2009: > Connect: 9A3LI-1:1024 9A1CRA:24 5
21:47 UTC Nov-2-2009: Added 9A3LI-1 to link list
21:47 UTC Nov-2-2009: Send>APRS-IS:9A1CRA>PSKAPR,TCPIP*::PSKAPR
:GATING 9A3LI-1
21:47 UTC Nov-2-2009: Added 9A3LI-1 to link list
21:47 UTC Nov-2-2009: Send>APRS-IS:9A1CRA>PSKAPR,TCPIP*::PSKAPR
:GATING 9A3LI-1
21:47 UTC Nov-2-2009: Added 9A3LI-1 to link list
21:47 UTC Nov-2-2009: Send>APRS-IS:9A1CRA>PSKAPR,TCPIP*::PSKAPR
:GATING 9A3LI-1
21:47 UTC Nov-2-2009: Added 9A3LI-1 to link list
21:47 UTC Nov-2-2009: Send>APRS-IS:9A1CRA>PSKAPR,TCPIP*::PSKAPR
:GATING 9A3LI-1
21:48 UTC Nov-2-2009: Added 9A3LI-1 to link list
21:48 UTC Nov-2-2009: Send>APRS-IS:9A1CRA>PSKAPR,TCPIP*::PSKAPR
:GATING 9A3LI-1
21:48 UTC Nov-2-2009: Call 9A3LI-1 o.k.
(five times ?? )
and then:
21:48 UTC Nov-2-2009: Connected to 9A3LI-121:48 UTC Nov-2-2009:
Listening to the radio

(listen again? no connect? )
In the same time station 9A7AOF-9 trying to connect server 9A1CRA:

21:49 UTC Nov-2-2009: Already connected to 9A7AOF-9, 9A3LI-1
21:50 UTC Nov-2-2009: Already connected to 9A7AOF-9, 9A3LI-1

Who is "main" station there?
Server then "hangs" until restart or 9A3LI connect it again and send "quit"
but that "quit" must be properly recived by server.
There is no confirmation on client disconnect task or we doing something wrong?

One more example:
09:15 UTC Nov-3-2009: > Unproto: 9A7AOF-9><9A1CRA

09:15 UTC Nov-3-2009: Added 9A7AOF-9 to list
09:15 UTC Nov-3-2009: Send>APRS-IS:9A1CRA>PSKAPR,TCPIP*::PSKAPR
:GATING 9A7AOF-9
----------------
09:15 UTC Nov-3-2009: > Connect: 9A7AOF-9:1024 9A1CRA:24 5
----------------
09:15 UTC Nov-3-2009: Already connected to 9A7AOF-9, 9A6DNO
---------------

9A6DNO has weak signal and he lost connection but server keep it connected
for some undefined time.
All unproto passed without problem, connection is unpossible.

Thats all for now, we keep playing, its very fun !

Best regards!

Darko
9A3LI


Other related posts: