[pskmail] Re: Odd JPSKMail and FLDigi issue

  • From: John Douyere <vk2eta@xxxxxxxxx>
  • To: pskmail@xxxxxxxxxxxxx
  • Date: Thu, 24 Dec 2009 09:00:22 +1100

Hello David,

I sent a proposed concept yesterday to this group. Since I haven't had
more feedback on it I will propose these code changes to the Fldigi
dev group.

The concept will be to have a tick box in the psk configuration / mail
section to limit the psk modes (bpsk, qpsk and pskr) to 250 maximum
when receiving either an RSID or a request by the server/client for
mode change. Like a speed limiter principle.

Operator initiated mode changes would still be control free
irrespective of Fldigi mode (i.e. as a modem or standalone).

Regards,

John

On Thu, Dec 24, 2009 at 6:18 AM, DAVID GRAY <kf4wbs@xxxxxxxxxxx> wrote:
> GOT IT   MY FIREWALL WAS BLOCKING IT      I HAD IT SET NOT TO NOTIFY OF NEW
> CONNECTION ATTEMPTS
> SO IT TRIED FAILED AND THEN JUST CLOSED DOWN
>
> HA   I WAS PULLING MY HAIR OUT
>
> HOW DO I LIMIT SERVER TO PSK 250    FOR USE HERE IS THE STATES?
> I BELONG TO MARS     SO I WOULD LIKE TO BE ABLE TO USE PSK 500  BUT ALSO
> TURN IT OFF
>
> DAVID GRAY   KF4WBS
>
> --------------------------------------------------
> From: "John Douyere" <vk2eta@xxxxxxxxx>
> Sent: Wednesday, December 23, 2009 03:55
> To: <pskmail@xxxxxxxxxxxxx>
> Subject: [pskmail] Re: Odd JPSKMail and FLDigi issue
>
>> Hello David,
>>
>> Have you tried the configuration files deletion as mentioned in a
>> previous email of the same thread?
>>
>> Regards,
>>
>> John
>>
>> On Wed, Dec 23, 2009 at 11:36 AM, DAVID GRAY <kf4wbs@xxxxxxxxxxx> wrote:
>>>
>>> I CAN T GET FLDIGI -BH TO OPEN IN WINDOWS XP
>>>
>>> IT INSTALLS BUT WONT RUN
>>>
>>> I GET
>>>
>>> RUNTIME ERROR
>>> PROGRAM:C:\FLDIGI-3.13BH\FLDIGI.EXE
>>>
>>> THIS APPLICATION HAS REQUESTED THE RUNTIME TO TERMINATE IT IN AN UNUSUSAL
>>> WAY,
>>> PLEASE CONTACT THE APPLICATION`S SUPPORT FOR MAORE INFORMATION
>>>
>>> DAVID KF4WBS
>>>
>>> --------------------------------------------------
>>> From: "Decossas, Michael" <Mike@xxxxxxxxxxxx>
>>> Sent: Tuesday, December 22, 2009 19:19
>>> To: <pskmail@xxxxxxxxxxxxx>
>>> Subject: [pskmail] Re: Odd JPSKMail and FLDigi issue
>>>
>>>> Of course....
>>>>
>>>> WinXP Pro, SP2
>>>> Icom 746PRO
>>>> Signalink USB Interface
>>>> G4ZLP CI/V cable....
>>>>
>>>> Thanks,
>>>>
>>>> Mike
>>>>
>>>> ________________________________________
>>>> From: pskmail-bounce@xxxxxxxxxxxxx [pskmail-bounce@xxxxxxxxxxxxx] On
>>>> Behalf Of John Douyere [vk2eta@xxxxxxxxx]
>>>> Sent: Tuesday, December 22, 2009 6:18 PM
>>>> To: pskmail@xxxxxxxxxxxxx
>>>> Subject: [pskmail] Re: Odd JPSKMail and FLDigi issue
>>>>
>>>> Hi Michael,
>>>>
>>>> Interesting, so to speak.
>>>>
>>>> I will post this issue in the fldigi alpha group mailing list and see
>>>> if I get something.
>>>>
>>>> Can you give me more details on your setup please:
>>>>
>>>> Service pack of XP pro, rig, device to talk to the rig, etc...
>>>>
>>>> 73s,
>>>>
>>>> John
>>>>
>>>> On Wed, Dec 23, 2009 at 11:00 AM, Decossas, Michael <Mike@xxxxxxxxxxxx>
>>>> wrote:
>>>>>
>>>>> Also, if I disable the CAT control, no error in Fldigi is
>>>>> generated.....
>>>>>
>>>>> Corrupt XML file?
>>>>>
>>>>> ________________________________________
>>>>> From: pskmail-bounce@xxxxxxxxxxxxx [pskmail-bounce@xxxxxxxxxxxxx] On
>>>>> Behalf Of Decossas, Michael [Mike@xxxxxxxxxxxx]
>>>>> Sent: Tuesday, December 22, 2009 5:55 PM
>>>>> To: pskmail@xxxxxxxxxxxxx
>>>>> Subject: [pskmail] Re: Odd JPSKMail and FLDigi issue
>>>>>
>>>>> John,
>>>>> Uninstalled 3.12.5 and deleted the files you recommended. Installed
>>>>> 3.13BH. Reconfigured Fldigi and it came up just fine. Once I started
>>>>> JPSKMail, the infamous "Fast Light Digital Modem Application has
>>>>> encountered
>>>>> a problem and needs to close." This happened twice. I restarted both
>>>>> JPSKMail and Fldigi and as soon as JPSKMail starts, the error is
>>>>> generated.
>>>>>
>>>>> Also, when restarting Fldigi, I get a hamlib_init: IO error.
>>>>>
>>>>> I also tried Rigcat and the error is: "W: rigcat_getfreq:Retries
>>>>> failed"
>>>>>
>>>>> This seems to be a radio control problem, not PSKmail...
>>>>>
>>>>> Thoughts?
>>>>>
>>>>> Thanks,
>>>>>
>>>>> Mike
>>>>>
>>>>> ________________________________________
>>>>> From: pskmail-bounce@xxxxxxxxxxxxx [pskmail-bounce@xxxxxxxxxxxxx] On
>>>>> Behalf Of John Douyere [vk2eta@xxxxxxxxx]
>>>>> Sent: Tuesday, December 22, 2009 5:35 PM
>>>>> To: pskmail@xxxxxxxxxxxxx
>>>>> Subject: [pskmail] Re: Odd JPSKMail and FLDigi issue
>>>>>
>>>>> Hi Mike,
>>>>>
>>>>> I strongly suspect that 3.12.5 still has an issue that is fixed in
>>>>> 3.13 alphas: it locks up when one command string is sent before the
>>>>> previous one is completely processed.
>>>>>
>>>>> And in the new versions of jpskmail we do a lot of that with RSID
>>>>> switching and data strings sent one after the other very rapidly.
>>>>>
>>>>> So if we could get your 3.13 version working under XP Pro (which I
>>>>> have here and it is working fine), that would fix your problem.
>>>>>
>>>>> May I suggest, if you haven't tried before, that after you install
>>>>> 3.13BH or later, can you try to delete the files below before you run
>>>>> the program so that the configuration is started from fresh again. I
>>>>> noticed that this is the cause of a lot of issues when upgrading.
>>>>>
>>>>> Delete:
>>>>>
>>>>> C:\Documents and settings\<your_login_name>\fldigi.files\fldigi.prefs
>>>>>
>>>>> and
>>>>>
>>>>> C:\Documents and settings\<your_login_name>\fldigi.files\fldigi_def.xml
>>>>>
>>>>> Alternatively just delete the whole fldigi.files directory, but that
>>>>> would remove any customized macros you stored before.
>>>>>
>>>>> Regards,
>>>>>
>>>>> John
>>>>>
>>>>> On Wed, Dec 23, 2009 at 10:13 AM, Decossas, Michael <Mike@xxxxxxxxxxxx>
>>>>> wrote:
>>>>>>
>>>>>> All,
>>>>>> I have noticed this before, but haven't sent this to the list
>>>>>> yet...
>>>>>>
>>>>>> Running Fldigi 3.12.5 (can't get 13 to run without generating
>>>>>> exceptions
>>>>>> on
>>>>>> XP Pro) and JPSKMail 0.4.0.2.
>>>>>>
>>>>>> I just connected to NC5O. I went ot update my records and JPSKMail
>>>>>> shows
>>>>>> a
>>>>>> transmit, but Fldigi never sent the data. Kind of like Fldigi is
>>>>>> ignoring
>>>>>> JPSKMail...
>>>>>>
>>>>>> Anyone ever see this before?
>>>>>>
>>>>>> Thanks,
>>>>>>
>>>>>> Mike-KB5OZE
>>>>>
>>>>
>>>
>>>
>>
>>
>
>

Other related posts: