[pskmail] Re: Client and server problems!

  • From: Rein Couperus <rein@xxxxxxxxxxxx>
  • To: pskmail@xxxxxxxxxxxxx
  • Date: Thu, 12 Mar 2009 11:53:04 +0100

No, I was talking about the pskmail server... this is the code in 
rflinkserver.pl

sub send_mail {

############################################################

    my($to, $from, $subject, @body)= @_;

    my $smtp;



        if ($smtpauthlevel != 2)  # Will not use TLS Auth

        {

                $smtp = Net::SMTP->new($relay, Debug => 1);

                die "Could not open connection: $!" unless $smtp;

                if ($smtpauthlevel == 1 && $smtptlsuser ne '')  # Plain AUTH 
here

                {

                        if ( !$smtp->auth($smtptlsuser, $smtptlspass) ) {

                                logprint ("SMTP authentication failed or is not 
needed.\n");

                        }

                }

        }

Are you on skype or jabber?

73,

Rein PA0R


> -----Ursprüngliche Nachricht-----
> Von: "Steve" <stevez@xxxxxxxxxx>
> Gesendet: 12.03.09 11:43:08
> An: pskmail@xxxxxxxxxxxxx
> Betreff: [pskmail] Re: Client and server problems!


> Yep, return address is set.
> Were you talking about setting up debug on the PSKMail server, or the 
> sendmail server?
> I can't debug the sendmail server as it belongs to my ISP!
> 
> Thanks for the quick reply Rein.
> 
> 
> Rein Couperus wrote:
> > Have you set the proper return address? Most SMTP servers will refuse to 
> > send 
> > mail if they don't get a valid one.
> >
> > If the server is set to debug mail you can see the smtp session in the 
> > server terminal,
> > which should give you the error message of the smtp server.
> > (we have seen things like 'I can break rules too')
> >
> > 73,
> >
> > Rein PA0R
> >
> >   
> >> -----Ursprüngliche Nachricht-----
> >> Von: "Steve" <stevez@xxxxxxxxxx>
> >> Gesendet: 12.03.09 11:13:43
> >> An: pskmail@xxxxxxxxxxxxx
> >> Betreff: [pskmail] Client and server problems!
> >>     
> >
> >
> >   
> >> Hello all,
> >>
> >> I'm making some progress on getting VK2ZSZ-1 server up, but am having 
> >> some problems.
> >>
> >> First, a quick note about the client.
> >> When it starts up, it would not talk to FLdigi. As soon as the client 
> >> started, it asked FLDigi to transmit MULTIPSK-OFF (which it did transmit).
> >> After that, the client and FLdigi would no longer talk. I fixed this by 
> >> commenting out the line "print $socket $pskmailon;" in psk_arq.pl .
> >> Has anyone else seen this?
> >> Latest PSKMail client. FLdigi 3.10 (via Fedora 10 repositories - also 
> >> tried pre-compiled binaries from the author's web pake).
> >>
> >>
> >> Now for my server problems. Everything is working (web, POP3, APRS) - 
> >> except sending emails.
> >> It isn't talking SMTP to my local ISP's sendmail server properly.
> >> I can send emails OK by telnetting into the SMTP server (port 25) and 
> >> manually forming an email. It doesn't need authentication.
> >> Could the problem only be that my mail looks like it is coming from 
> >> "localhost.localdomain"?
> >> Any idieas? I'm almost there (and still excited about PSKMail!)
> >>
> >> Thanks all,
> >> Steve (VK2ZSZ)
> >>
> >>
> >> Here are some snippets from the log :-
> >>
> >> 17:35 UTC Mar-12-2009: Receiving mail
> >> To: kl@xxxxxxxxxx
> >> Subject: Test
> >> Test
> >> .
> >> Net::SMTP>>> Net::SMTP(2.31)
> >> Net::SMTP>>>   Net::Cmd(2.29)
> >> Net::SMTP>>>     Exporter(5.62)
> >> Net::SMTP>>>   IO::Socket::INET(1.31)
> >> Net::SMTP>>>     IO::Socket(1.30_01)
> >> Net::SMTP>>>       IO::Handle(1.27)
> >> 17:35 UTC Mar-12-2009: 0!s!""C06B
> >> 17:35 UTC Mar-12-2009:
> >> Net::SMTP=GLOB(0xa6861a4)<<< 220 mail.tpg.com.au ESMTP (mail5) Sendmail 
> >> ready.
> >> Net::SMTP=GLOB(0xa6861a4)>>> EHLO localhost.localdomain
> >> Net::SMTP=GLOB(0xa6861a4)<<< 250-mail5.tpgi.com.au Hello 
> >> 61-242-105-47.tpgi.com.au [60.242.105.47], pleased to meet you
> >> Net::SMTP=GLOB(0xa6861a4)<<< 250-ENHANCEDSTATUSCODES
> >> Net::SMTP=GLOB(0xa6861a4)<<< 250-PIPELINING
> >> Net::SMTP=GLOB(0xa6861a4)<<< 250-8BITMIME
> >> Net::SMTP=GLOB(0xa6861a4)<<< 250-SIZE 28521268
> >> Net::SMTP=GLOB(0xa6861a4)<<< 250-DSN
> >> Net::SMTP=GLOB(0xa6861a4)<<< 250-AUTH LOGIN PLAIN
> >> Net::SMTP=GLOB(0xa6861a4)<<< 250-STARTTLS
> >> Net::SMTP=GLOB(0xa6861a4)<<< 250-DELIVERBY
> >> Net::SMTP=GLOB(0xa6861a4)<<< 250 HELP
> >> 17:35 UTC Mar-12-2009: Connection open...
> >> Net::SMTP=GLOB(0xa6861a4)>>> MAIL FROM:<sremote@xxxxxxxxxx>
> >> Net::SMTP=GLOB(0xa6861a4)<<< 550 5.7.1 <sremote@xxxxxxxxxx>... HELO 
> >> localhost.localdomain from RFC 2606 reserved domains blocked
> >> Net::SMTP=GLOB(0xa6861a4)>>> RCPT TO:<kl@xxxxxxxxxx>
> >> Net::SMTP=GLOB(0xa6861a4)<<< 503 5.0.0 Need MAIL before RCPT
> >> Net::SMTP=GLOB(0xa6861a4)>>> DATA
> >> Net::SMTP=GLOB(0xa6861a4)<<< 503 5.0.0 Need MAIL command
> >> Net::SMTP=GLOB(0xa6861a4)>>> To: kl@xxxxxxxxxx
> >> Net::SMTP=GLOB(0xa6861a4)>>> From: sremote@xxxxxxxxxx
> >> Net::SMTP=GLOB(0xa6861a4)>>> Date: Fri, 13 Mar 2009 04:35:24 CST
> >> Net::SMTP=GLOB(0xa6861a4)>>> Reply-To: sremote@xxxxxxxxxx
> >> Net::SMTP=GLOB(0xa6861a4)>>> Subject: Test
> >> Net::SMTP=GLOB(0xa6861a4)>>> Comments: Via PskMail.
> >> Net::SMTP=GLOB(0xa6861a4)>>>
> >> Net::SMTP=GLOB(0xa6861a4)>>> PSKmail message from sremote@xxxxxxxxxx
> >> Net::SMTP=GLOB(0xa6861a4)>>> Test
> >> Net::SMTP=GLOB(0xa6861a4)>>> .
> >> Net::SMTP=GLOB(0xa6861a4)<<< 500 5.5.1 Command unrecognized: "To: 
> >> kl@xxxxxxxxxx"
> >> Net::SMTP=GLOB(0xa6861a4)>>> QUIT
> >> Net::SMTP=GLOB(0xa6861a4)<<< 500 5.5.1 Command unrecognized: "From: 
> >> sremote@xxxxxxxxxx"
> >>
> >>
> >>     
> >
> >   
> 
> 
> 

-- 
http://pa0r.blogspirit.com

Other related posts: