[pskmail] Re: Aw: Re: Error with new client/server

  • From: Glenn Roeser <wb2lmv@xxxxxxxxx>
  • To: pskmail@xxxxxxxxxxxxx
  • Date: Sun, 31 Mar 2013 12:58:03 -0400

Thanks Rein, now I wonder...I'm using a different lap top and I installed
Lubuntu 12.10 on it, and then the new server yesterday. Before I was using
Lubuntu 12.04 with the old server. Could that have made the difference?
Glenn WB2LMV


On Sun, Mar 31, 2013 at 12:54 PM, Rein Couperus <rein@xxxxxxxxxxxx> wrote:

> This particular 'corrupted' file comes from an update in the perl runtime
> environment, the present version of SSL.pm has a bug.
> It is normal that bugs are generated when software is updated.
> In this case there has been a change of maintainer for the library.
> I still had the old library on my systems, so i did not notice.
> That is what field testing is for...
>
> I will have to distribute this old version of SSL.pm together with the new
> server...
>
> Tnx for the testing...
>
> 73,
>
> Rein PA0R
>
>
>
>  That worked Rein.... Where did these corrupted files come from?
> the Linux kernel? We had a perfectly working server and client, you made
> some new improvements and now you have to find old files to place in the
> new server? I'm sorry, but I don't understand....
> Glenn
>
>
> On Sun, Mar 31, 2013 at 11:24 AM, Rein Couperus <rein@xxxxxxxxxxxx> wrote:
>
>> what does 'ls -l /usr/share/perl5/IO/Socket/SSL.pm' say?
>>
>> I remember having to change this file to make it work. You probably have
>> the
>> original perl lib. which has a bug in some distros... see:
>>
>>    1. invalid SSL_version specified at /usr/share/perl5 - Launchpad 
>> Bugs<https://www.google.nl/url?sa=t&rct=j&q=&esrc=s&source=web&cd=3&cad=rja&ved=0CD8QFjAC&url=https%3A%2F%2Fbugs.launchpad.net%2Fbugs%2F1072299&ei=6VRYUcGAJ8STOKbhgOgM&usg=AFQjCNErU9FwudbprZRqkkXZmwxpxL7Z3Q&sig2=U3p7CLu-wQ45sp1fno5Q7g&bvm=bv.44442042,d.ZWU>
>>     bugs.launchpad.net › Ubuntu <https://launchpad.net/ubuntu> › “sendemail”
>>    package <https://launchpad.net/ubuntu/+source/sendemail> › 
>> Bugs<https://bugs.launchpad.net/ubuntu/+source/sendemail>
>>    Oct 28, 2012 – invalid SSL_version specified at
>>    /usr/share/perl5/IO/Socket/SSL.pm line 332. Ubuntu · “sendemail”
>>    package · Bugs; Bug #1072299. Reported *...*
>>
>> If yours is > 80k bytes it is the wrong one...
>> Try the attached one, that is the one I am using on PI4TUE...
>>
>> Rein
>>
>>
>>  When trying to send an email using the new server 2.0.17 / client
>> 2.0.33 I receive this:
>>
>> Error sending mail : invalid SSL_version specified at
>> /usr/share/perl5/IO/Socket/SSL.pm line 332
>>
>>
>> Everything worked fine before changing to the new versions
>>
>> Glenn WB2LMV
>>
>>
>
>

Other related posts: