[pskmail] Re: Aw: PSKMail Server & IC-7200

  • From: Josh Housey <kg9bo@xxxxxxxxx>
  • To: "pskmail@xxxxxxxxxxxxx" <pskmail@xxxxxxxxxxxxx>
  • Date: Sat, 30 Jun 2012 22:20:10 -0700 (PDT)

Rein and all,

I have put my computer back to Xubuntu 12.04. It runs just a little bit 
different then the others. I put in Fldigi 3.21.47 (just saw it was posted) and 
used your screenshot to set up Hamlib for the 7200. Reinstalled 1.8 and used 
what I had originally everything is running smoothly so far... If I continue to 
have problems over a week, it might be resolved. My guess is that I think its 
fixed and it makes more sense to be running hamlib instead of rigcat. Its more 
designed for that purpose. 

 Also,  seeing that new installation of PSKMail server is doing well on 30m. We 
have been experiencing rather enhanced propagation on VHF other here (Lake 
Michigan) and, tends to "distort" HF propagation on some modes (packet), but 
doesn't with PSKMail. I have had extremely consistent copy of KB2PNM who also 
seems to copy me as I see a rather consistent amount of APRS-IS packets coming 
from throughout the entire day and about half of the night so far.

I asked some questions in a previous e-mail and they are not entirely necessary 
for a response.  I would be curious to know if you would suggest using either 
direct ALSA for the sound card for portaudio or simply to use pulseaudio (not 
"pulse" in port audio which is what I did before in Fedora that wasn't working) 
for Fldigi? 


Otherwise, I was thinking about something in pskmailrc.pl and that as 
TRAFFIC_QRG option. What does that specifically do? Does anyone use it?  I was 
just thinking about the "APRS" function of pskmail (on other channel) is why I 
brought it up...

Another question that I just thought up. I remember reading in documentation 
that the APRS status beacon can be changed to put in, as example states, an 
APRS "weather" information. Could this be done with the beacon that is 
transmitted over RF? If not, could another beacon be put in to transmit a WX 
beacon that could be received if another station would have Xastir/jpskmail set 
up? At least in my opinion, that would be interesting... 

Just looking to explore other venues with pskmail...


Any input is appreciated...

73
Josh, AB9FT


________________________________
 From: Rein Couperus <rein@xxxxxxxxxxxx>
To: pskmail@xxxxxxxxxxxxx 
Sent: Thursday, June 28, 2012 2:26 AM
Subject: [pskmail] Aw: PSKMail Server & IC-7200
 

Josh,


There is one thing which comes to my mind immediately...

The PSKmail server uses hamlib to control the frequency and the PTT of the rig.
I expect problems when you use RIGCAT.
Attached is the pic of the parameters I use on the PI4TUE server.
I use VOX instead of PTT, that works very well.

The lockups you see are most probably caused by RF on the USB connection.
On PI4TUE I have used ferrites to kill the RF on the cable, additional to 
effictive grounding of the rig.

We have strong indications that  lockups are NOT caused by the server software.
The operating system does also not play any roll, lockups happen on any...
The fldigi problem is caused by the error handling of the ARQ interface in 
fldigi. When RF causes errors on the USB connection, the error is not 
handled properly in fldigi, and the ARQ routine is halted.

I have meanwhile written a small scipt which will restart fldigi after 5 
minutes 

when the ARQ interface dies. It is being tested on PI4TUE now, and it will be 
published 
soon...

But the best cure is to make sure the USB connection does not produce errors...

73,

Rein PA0R


All,

Name here is Josh, (AB9FT) from Sheboygan, Wisconsin (50mi N of Milwaukee along 
Lake Michigan)

30m conditions haven't been the best here past few days, if that is why some 
have not heard the server here. Trying out KAM+ on 30 (test propagation) and 
actually hearing very little as well. More one way with "packet" TX/RX then 
with PSKMail I have very regular copy of KB2PNM on 30m... Anyway, I have been 
having a problem with the server here with my IC-7200. It is a random problem 
that has no specific time but seems to eventually happen.. It can be either in 
the ID (where I have noticed it happens more often) but simply when its done 
transmitting, it gets "jammed" and continues to transmit until I turn the radio 
off. When that happens, fldigi apparently hangs and have to "kill" it. I am 
wondering if my problem is related to anyway to SA6BQZ's problem.... On some 
cases, it loses communication with the radio with a message about (Radio IO 
failed....). I should mention that I have it set up that it uses RigCAT with 
the IC-7200.xml that keys up the radio
 and has that special  "command (can't remember, its not NO500....)" to ensure 
the 7200 can key up with PSKMail Server

I have tried to troubleshoot as much as I can and getting nowhere with it. 
Started with different USB cables... Tried different linux distros (Lubuntu, 
Xubuntu, Slackware, Fedora, Mint, Debian) and different software combinations 
(newer/older versions) and get the same thing... Also, it happens whether I use 
frequency/scanning.. Pretty sure, its nothing I have set up for files, but send 
them if that will help. Beginning to wonder if its the computer, but that would 
be strange....

If anyone has any suggestions, please feel free to mention.

Thanks.

73
Josh, AB9FT

Other related posts: