[prssr-devel-ml] Bug: "Copy Item URL" in item view is sometimes wrong

  • From: Joerg <prss-dev@xxxxxxxxxxxxxxxx>
  • To: prssr-devel-ml@xxxxxxxxxxxxx
  • Date: Sat, 27 May 2006 10:02:55 +0200

Hi David,

the function "Copy Item URL" copies the wrong URL when called from the
context menu whithin an open item. The URL copied is sometimes the one
of the previous item but it seems to be somewhat random.

Steps to reproduce:
1) Open an item within the first feed (other feeds seem normal this
time, but see below)
2) Tap and hold somewhere in the message
3) Select "Copy Item URL"
4) Paste it somewhere

I confirmed it's not the feed's fault by copying the URL from the item
list. (One of the feeds is http://www.tagesschau.de/newsticker.rdf)

Unfortunately the error does not seem to appear constantly. While seen
twice (yesterday and today) and the device was rebooted between those
appearances, the problem disappeared after several items while testing.

This may be related to another problem: when leaving a message
pRSSreader sometimes selects (blue background, just like the regular
selection bar) several or all messages of the feed. Sometimes this "odd"
selections stays until I move the cursor or tap an item, sometimes it
disappears with a little flickering of the list. This happens *very*
irregularly and with all feeds I am subscribed to.

Tested in pRSSreader 1.3.1 on Windows Mobile 2003 SE.

pRSSreader development mailing list

Other related posts:

  • » [prssr-devel-ml] Bug: "Copy Item URL" in item view is sometimes wrong