[prssr-devel-ml] Re: 1.3.3 beta 4

  • From: David Andrs <pda@xxxxxxxxxxxxx>
  • To: prssr-devel-ml@xxxxxxxxxxxxx
  • Date: Wed, 24 Jan 2007 21:49:32 -0700

I'd like to help you with this, but you understand that it is very hard,
becuase I'm not able to emulate your environment on my device to debug it.

For 1.3.3, I have added https support, but it still has some limitations
with proxies.

The rest of HTTP implementation should be the same. I made some fixes,
but they were extending not restricting ones.

Thomas M. Hofmann wrote:
> Hi again,
> 
> Maybe this has to do with HTTP 1.1 and maybe the proxy only supports
> 1.0. I am guessing this because of the HTTP error code 400 I get with
> 1.3.3.
> 
> Did this change? Did 1.3.2 use HTTP 1.0?
I do not thing so, but not completely sure about it. HTTP 1.0 is used if
you are using HTTP proxy, but 1.3.3 uses also HTTP 1.0. So, no changes here.

--
David

> 
> What else change in HTTP protocol that could lead to the error 400?
> 
> Thomas=20
> 
> -----Original Message-----
> From: prssr-devel-ml-bounce@xxxxxxxxxxxxx
> [mailto:prssr-devel-ml-bounce@xxxxxxxxxxxxx] On Behalf Of Thomas M.
> Hofmann
> Sent: Montag, 22. Januar 2007 9:10
> To: prssr-devel-ml@xxxxxxxxxxxxx
> Subject: [prssr-devel-ml] Re: 1.3.3 beta 4
> 
> Hi David,
> 
> I checked for typos. Unfortunately I did not export the registry before
> I uninstalled 1.3.2.
> 
> When I uninstalled 1.3.2 I left the cache data untouched and then I
> installed the 1.3.3 beta4 into the same location.
> 
> Another thing that I noticed is that with 1.3.2 I would sometimes need
> to close pRSS and then start Pocket IE, load a page and then restart
> pRSS to get it to connect successfully.
> 
> I saw a similar problem back in autum 2006 on this list but now answer
> as far as I remember.
> 
> So if nothing regarding the Additonal HTTP Headers has do you have some
> advice on how I can get more info about this is not working anymore. I
> get Error 400 which I do not remember getting before.
> 
> Thanks
> 
> -----Original Message-----
> From: prssr-devel-ml-bounce@xxxxxxxxxxxxx
> [mailto:prssr-devel-ml-bounce@xxxxxxxxxxxxx] On Behalf Of David Andrs
> Sent: Montag, 22. Januar 2007 6:46
> To: prssr-devel-ml@xxxxxxxxxxxxx
> Subject: [prssr-devel-ml] Re: 1.3.3 beta 4
> 
> No changes regarding this. Maybe some typo in additional HTTP headers or
> user agent string?
> 
> Moreover, have you uninstall 1.3.2 before installing 1.3.3? If not, you
> will need to uninstall 1.3.3, may be you will have to do manual clean
> and then do the clean install.
> 
> --
> David
> 
> Thomas M. Hofmann wrote:
>> Hi,
>> =3D20
>> Today I installed 1.3.3 beta 4 coming from 1.3.2. I am trying to use
> the
>> O2 WAP falt with pRSS and got everything working with 1.3.2. I had
>> changed the User Agent string to match my pocket ie and I also added
> the
>> "Addtional HTTP Headers" registry key.
>> =3D20
>> Now, that I installed 1.3.3 beta4 and recreated the registry settings
> I
>> get HTTP error 400 all the time when I try to update my news =3D
> feeds.=3D3D20
>> =3D20
>> Are there any changes regarding this?
>> =3D20
>> Thank you.
>> =3D20
>> Thomas
>> --
>> pRSSreader development mailing list
>> prssr-devel-ml@xxxxxxxxxxxxx
>> http://www.freelists.org/archives/prssr-devel-ml
>> =3D20
>> =3D20
>> =3D20
> --
> pRSSreader development mailing list
> prssr-devel-ml@xxxxxxxxxxxxx
> http://www.freelists.org/archives/prssr-devel-ml
> 
> 
> 
> --
> pRSSreader development mailing list
> prssr-devel-ml@xxxxxxxxxxxxx
> http://www.freelists.org/archives/prssr-devel-ml
> 
> 
> 
> --
> pRSSreader development mailing list
> prssr-devel-ml@xxxxxxxxxxxxx
> http://www.freelists.org/archives/prssr-devel-ml
> 
> 
> 
--
pRSSreader development mailing list
prssr-devel-ml@xxxxxxxxxxxxx
http://www.freelists.org/archives/prssr-devel-ml


Other related posts: