[project1dev] Re: Project1 - SVN Update 142

  • From: Alan Wolfe <alan.wolfe@xxxxxxxxx>
  • To: project1dev@xxxxxxxxxxxxx
  • Date: Tue, 19 May 2009 18:14:06 -0700

oh you know what Chris...

that just means that the bottleneck for the game on your computer isn't your
CPU.

That just says that the game is a bigger load to your GPU than it is your
CPU, so your CPU normally sits around waiting for your GPU to be finished,
but in this case when the CPU had more work to do, it still wasn't enough to
make it not have to wait on the GPU.
On Tue, May 19, 2009 at 6:07 PM, Chris Riccobono <crysalim@xxxxxxxxx> wrote:

> Yeah, vsync off is the only way I could tell
>
> Nick, I'm going to upload a different path - tell me if this still
> keeps your system slow ok?
>
> On Tue, May 19, 2009 at 6:07 PM, Alan Wolfe <alan.wolfe@xxxxxxxxx> wrote:
> > even with vsync off?
> >
> > On Tue, May 19, 2009 at 6:06 PM, Chris Riccobono <crysalim@xxxxxxxxx>
> wrote:
> >>
> >> No it doesn't.. dunno why.
> >>
> >> On Tue, May 19, 2009 at 6:04 PM, Alan Wolfe <alan.wolfe@xxxxxxxxx>
> wrote:
> >> > if you remove mob5 from your script does your FPS jump up?
> >> >
> >> > On Tue, May 19, 2009 at 6:03 PM, Chris Riccobono <crysalim@xxxxxxxxx>
> >> > wrote:
> >> >>
> >> >> Actually Alan I take that back, it was just cuz I set the game to
> zoom
> >> >> out a lot more in my config :/
> >> >>
> >> >> I can't get the framerate to drop or increase by changing mob 5
> >> >> pathing at all :(
> >> >>
> >> >> On Tue, May 19, 2009 at 6:00 PM, Alan Wolfe <alan.wolfe@xxxxxxxxx>
> >> >> wrote:
> >> >> > neato, good times (:
> >> >> >
> >> >> > On Tue, May 19, 2009 at 5:59 PM, Chris Riccobono <
> crysalim@xxxxxxxxx>
> >> >> > wrote:
> >> >> >>
> >> >> >> You're right Alan, when I turned off vsync it was a lot slower
> than
> >> >> >> usual (100 fpsish)
> >> >> >>
> >> >> >>
> >> >> >> On Tue, May 19, 2009 at 5:54 PM, Alan Wolfe <alan.wolfe@xxxxxxxxx
> >
> >> >> >> wrote:
> >> >> >> > probably cause you have such a beefy system you are still pegged
> >> >> >> > at
> >> >> >> > 60fps
> >> >> >> > (or whatever your vsync is at).
> >> >> >> >
> >> >> >> > If you had vsync off youd probably notice a drop.  Like "hey its
> >> >> >> > running
> >> >> >> > at
> >> >> >> > 200fps when it used to run at 400fps" or something like that
> hehe
> >> >> >> >
> >> >> >> > On Tue, May 19, 2009 at 5:52 PM, Chris Riccobono
> >> >> >> > <crysalim@xxxxxxxxx>
> >> >> >> > wrote:
> >> >> >> >>
> >> >> >> >> Yeah, I am not sure what it is Alan because I can't replicate
> the
> >> >> >> >> problem.. I am going to move the path down by 10 Y points and
> see
> >> >> >> >> if
> >> >> >> >> that fixes it for Nick.
> >> >> >> >>
> >> >> >> >> On Tue, May 19, 2009 at 5:48 PM, Alan Wolfe
> >> >> >> >> <alan.wolfe@xxxxxxxxx>
> >> >> >> >> wrote:
> >> >> >> >> > well z fighting makes things ugly but it doesnt hurt
> >> >> >> >> > preformance
> >> >> >> >> >
> >> >> >> >> > it's gotta be the collision detection slowing the game down
> but
> >> >> >> >> > i
> >> >> >> >> > cant
> >> >> >> >> > think
> >> >> >> >> > of why it would in this case
> >> >> >> >> > On Tue, May 19, 2009 at 5:45 PM, Chris Riccobono
> >> >> >> >> > <crysalim@xxxxxxxxx>
> >> >> >> >> > wrote:
> >> >> >> >> >>
> >> >> >> >> >> Thanks Nick, that gave me an idea of what might be the
> >> >> >> >> >> problem.
> >> >> >> >> >>
> >> >> >> >> >> The mob clips the barrel slightly, so when the two models
> meet
> >> >> >> >> >> it
> >> >> >> >> >> might be rendering something incorrectly (like with the Z
> >> >> >> >> >> fighting
> >> >> >> >> >> issues)
> >> >> >> >> >>
> >> >> >> >> >> On Tue, May 19, 2009 at 5:39 PM, Nick Klotz
> >> >> >> >> >> <roracsenshi@xxxxxxxxx>
> >> >> >> >> >> wrote:
> >> >> >> >> >> > I removed Mob5 from the map and get 55-60fps again,
> however
> >> >> >> >> >> > it
> >> >> >> >> >> > still
> >> >> >> >> >> > takes
> >> >> >> >> >> > almost 2 minutes to load the map.
> >> >> >> >> >> >
> >> >> >> >> >> >
> >> >> >> >> >> >
> >> >> >> >> >> >
> >> >> >> >> >> > On Tue, May 19, 2009 at 7:33 PM, Alan Wolfe
> >> >> >> >> >> > <alan.wolfe@xxxxxxxxx>
> >> >> >> >> >> > wrote:
> >> >> >> >> >> >>
> >> >> >> >> >> >> i think kent had to run out, and i dunno cause i havent
> >> >> >> >> >> >> been
> >> >> >> >> >> >> able
> >> >> >> >> >> >> to
> >> >> >> >> >> >> check
> >> >> >> >> >> >> it out yet (still at work) :P
> >> >> >> >> >> >>
> >> >> >> >> >> >> On Tue, May 19, 2009 at 5:32 PM, Nick Klotz
> >> >> >> >> >> >> <roracsenshi@xxxxxxxxx>
> >> >> >> >> >> >> wrote:
> >> >> >> >> >> >>>
> >> >> >> >> >> >>> I have not been able to figure it out yet either.
> >> >> >> >> >> >>>
> >> >> >> >> >> >>>
> >> >> >> >> >> >>>
> >> >> >> >> >> >>>
> >> >> >> >> >> >>>
> >> >> >> >> >> >>> On Tue, May 19, 2009 at 7:19 PM, Chris Riccobono
> >> >> >> >> >> >>> <crysalim@xxxxxxxxx>
> >> >> >> >> >> >>> wrote:
> >> >> >> >> >> >>>>
> >> >> >> >> >> >>>> I'm trying to see what's wrong in the script for mob 5
> >> >> >> >> >> >>>> but I
> >> >> >> >> >> >>>> can't
> >> >> >> >> >> >>>> notice it, can you tell me?
> >> >> >> >> >> >>>>
> >> >> >> >> >> >>>> On Tue, May 19, 2009 at 4:58 PM, Kent Petersen
> >> >> >> >> >> >>>> <kentkmp@xxxxxxxxx>
> >> >> >> >> >> >>>> wrote:
> >> >> >> >> >> >>>> > found it. mob 5 is broken. dont have time to fix it
> >> >> >> >> >> >>>> > though.
> >> >> >> >> >> >>>> >
> >> >> >> >> >> >>>> > On Tue, May 19, 2009 at 4:52 PM, Kent Petersen
> >> >> >> >> >> >>>> > <kentkmp@xxxxxxxxx>
> >> >> >> >> >> >>>> > wrote:
> >> >> >> >> >> >>>> >>
> >> >> >> >> >> >>>> >> I'm betting its just a typo on the cavemap. I'm
> >> >> >> >> >> >>>> >> looking
> >> >> >> >> >> >>>> >> but
> >> >> >> >> >> >>>> >> not
> >> >> >> >> >> >>>> >> finding
> >> >> >> >> >> >>>> >> anything
> >> >> >> >> >> >>>> >>
> >> >> >> >> >> >>>> >> On Tue, May 19, 2009 at 4:51 PM, Nick Klotz
> >> >> >> >> >> >>>> >> <roracsenshi@xxxxxxxxx>
> >> >> >> >> >> >>>> >> wrote:
> >> >> >> >> >> >>>> >>>
> >> >> >> >> >> >>>> >>> Would definitely beneficial to find the root cause
> of
> >> >> >> >> >> >>>> >>> the
> >> >> >> >> >> >>>> >>> problem,
> >> >> >> >> >> >>>> >>> incase
> >> >> >> >> >> >>>> >>> something like this happens again.
> >> >> >> >> >> >>>> >>>
> >> >> >> >> >> >>>> >>>
> >> >> >> >> >> >>>> >>>
> >> >> >> >> >> >>>> >>> On Tue, May 19, 2009 at 6:49 PM, Alan Wolfe
> >> >> >> >> >> >>>> >>> <alan.wolfe@xxxxxxxxx>
> >> >> >> >> >> >>>> >>> wrote:
> >> >> >> >> >> >>>> >>>>
> >> >> >> >> >> >>>> >>>> hey if you right click your file you should be
> able
> >> >> >> >> >> >>>> >>>> to
> >> >> >> >> >> >>>> >>>> diff
> >> >> >> >> >> >>>> >>>> it
> >> >> >> >> >> >>>> >>>> against
> >> >> >> >> >> >>>> >>>> whats up on the server
> >> >> >> >> >> >>>> >>>>
> >> >> >> >> >> >>>> >>>> maybe you can see anything sticking out that might
> >> >> >> >> >> >>>> >>>> be
> >> >> >> >> >> >>>> >>>> causing
> >> >> >> >> >> >>>> >>>> a
> >> >> >> >> >> >>>> >>>> problem?
> >> >> >> >> >> >>>> >>>> (like 2 points being the exact same or something
> >> >> >> >> >> >>>> >>>> weird
> >> >> >> >> >> >>>> >>>> like
> >> >> >> >> >> >>>> >>>> that)
> >> >> >> >> >> >>>> >>>>
> >> >> >> >> >> >>>> >>>> On Tue, May 19, 2009 at 4:48 PM, Kent Petersen
> >> >> >> >> >> >>>> >>>> <kentkmp@xxxxxxxxx>
> >> >> >> >> >> >>>> >>>> wrote:
> >> >> >> >> >> >>>> >>>>>
> >> >> >> >> >> >>>> >>>>> I'm gonna undo Chris's cavemap update. I have
> found
> >> >> >> >> >> >>>> >>>>> that
> >> >> >> >> >> >>>> >>>>> my
> >> >> >> >> >> >>>> >>>>> problem
> >> >> >> >> >> >>>> >>>>> goes away if I use a previous version.
> >> >> >> >> >> >>>> >>>>>
> >> >> >> >> >> >>>> >>>>> On Tue, May 19, 2009 at 4:45 PM, Nick Klotz
> >> >> >> >> >> >>>> >>>>> <roracsenshi@xxxxxxxxx>
> >> >> >> >> >> >>>> >>>>> wrote:
> >> >> >> >> >> >>>> >>>>>>
> >> >> >> >> >> >>>> >>>>>> My game loads!  But on trying to enter the cave
> >> >> >> >> >> >>>> >>>>>> map;
> >> >> >> >> >> >>>> >>>>>> it
> >> >> >> >> >> >>>> >>>>>> now
> >> >> >> >> >> >>>> >>>>>> takes
> >> >> >> >> >> >>>> >>>>>> ~90
> >> >> >> >> >> >>>> >>>>>> seconds to load. Once loaded I get 1.21 to 1.50
> >> >> >> >> >> >>>> >>>>>> FPS.
> >> >> >> >> >> >>>> >>>>>>
> >> >> >> >> >> >>>> >>>>>>
> >> >> >> >> >> >>>> >>>>>>
> >> >> >> >> >> >>>> >>>>>> On Tue, May 19, 2009 at 6:35 PM, Kent Petersen
> >> >> >> >> >> >>>> >>>>>> <kentkmp@xxxxxxxxx>
> >> >> >> >> >> >>>> >>>>>> wrote:
> >> >> >> >> >> >>>> >>>>>>>
> >> >> >> >> >> >>>> >>>>>>> Damn same problem
> >> >> >> >> >> >>>> >>>>>>>
> >> >> >> >> >> >>>> >>>>>>> On Tue, May 19, 2009 at 4:20 PM, Kent Petersen
> >> >> >> >> >> >>>> >>>>>>> <kentkmp@xxxxxxxxx>
> >> >> >> >> >> >>>> >>>>>>> wrote:
> >> >> >> >> >> >>>> >>>>>>>>
> >> >> >> >> >> >>>> >>>>>>>> Tortoise was telling me that everything was
> >> >> >> >> >> >>>> >>>>>>>> good. I
> >> >> >> >> >> >>>> >>>>>>>> just
> >> >> >> >> >> >>>> >>>>>>>> deleted the
> >> >> >> >> >> >>>> >>>>>>>> whole folder and im re getting it now
> >> >> >> >> >> >>>> >>>>>>>>
> >> >> >> >> >> >>>> >>>>>>>> On Tue, May 19, 2009 at 4:11 PM, Alan Wolfe
> >> >> >> >> >> >>>> >>>>>>>> <alan.wolfe@xxxxxxxxx>
> >> >> >> >> >> >>>> >>>>>>>> wrote:
> >> >> >> >> >> >>>> >>>>>>>>>
> >> >> >> >> >> >>>> >>>>>>>>> it could be a bad merge if you have local
> >> >> >> >> >> >>>> >>>>>>>>> changes
> >> >> >> >> >> >>>> >>>>>>>>> that
> >> >> >> >> >> >>>> >>>>>>>>> aren't
> >> >> >> >> >> >>>> >>>>>>>>> checked in maybe :/
> >> >> >> >> >> >>>> >>>>>>>>>
> >> >> >> >> >> >>>> >>>>>>>>> On Tue, May 19, 2009 at 4:10 PM, Alan Wolfe
> >> >> >> >> >> >>>> >>>>>>>>> <alan.wolfe@xxxxxxxxx>
> >> >> >> >> >> >>>> >>>>>>>>> wrote:
> >> >> >> >> >> >>>> >>>>>>>>>>
> >> >> >> >> >> >>>> >>>>>>>>>> yeah let me know kent if re-downloading it
> >> >> >> >> >> >>>> >>>>>>>>>> solves
> >> >> >> >> >> >>>> >>>>>>>>>> it
> >> >> >> >> >> >>>> >>>>>>>>>> Kent
> >> >> >> >> >> >>>> >>>>>>>>>>
> >> >> >> >> >> >>>> >>>>>>>>>> On Tue, May 19, 2009 at 4:03 PM, Kent
> Petersen
> >> >> >> >> >> >>>> >>>>>>>>>> <kentkmp@xxxxxxxxx>
> >> >> >> >> >> >>>> >>>>>>>>>> wrote:
> >> >> >> >> >> >>>> >>>>>>>>>>>
> >> >> >> >> >> >>>> >>>>>>>>>>> May be a tortoise bug as well. I'll probly
> >> >> >> >> >> >>>> >>>>>>>>>>> redownload
> >> >> >> >> >> >>>> >>>>>>>>>>> the
> >> >> >> >> >> >>>> >>>>>>>>>>> whole
> >> >> >> >> >> >>>> >>>>>>>>>>> game if no one has the same problem
> >> >> >> >> >> >>>> >>>>>>>>>>>
> >> >> >> >> >> >>>> >>>>>>>>>>> On Tue, May 19, 2009 at 4:00 PM, Chris
> >> >> >> >> >> >>>> >>>>>>>>>>> Riccobono
> >> >> >> >> >> >>>> >>>>>>>>>>> <crysalim@xxxxxxxxx> wrote:
> >> >> >> >> >> >>>> >>>>>>>>>>>>
> >> >> >> >> >> >>>> >>>>>>>>>>>> I can't replicate it - I downloaded the
> >> >> >> >> >> >>>> >>>>>>>>>>>> entire
> >> >> >> >> >> >>>> >>>>>>>>>>>> distro
> >> >> >> >> >> >>>> >>>>>>>>>>>> to
> >> >> >> >> >> >>>> >>>>>>>>>>>> a
> >> >> >> >> >> >>>> >>>>>>>>>>>> new
> >> >> >> >> >> >>>> >>>>>>>>>>>> folder
> >> >> >> >> >> >>>> >>>>>>>>>>>> in case, and it works for me.. do you have
> >> >> >> >> >> >>>> >>>>>>>>>>>> any
> >> >> >> >> >> >>>> >>>>>>>>>>>> thoughts
> >> >> >> >> >> >>>> >>>>>>>>>>>> Alan?
> >> >> >> >> >> >>>> >>>>>>>>>>>>
> >> >> >> >> >> >>>> >>>>>>>>>>>> On Tue, May 19, 2009 at 3:53 PM, Kent
> >> >> >> >> >> >>>> >>>>>>>>>>>> Petersen
> >> >> >> >> >> >>>> >>>>>>>>>>>> <kentkmp@xxxxxxxxx> wrote:
> >> >> >> >> >> >>>> >>>>>>>>>>>> > maybe its just me. i get an inverse
> matrix
> >> >> >> >> >> >>>> >>>>>>>>>>>> > error.
> >> >> >> >> >> >>>> >>>>>>>>>>>> >
> >> >> >> >> >> >>>> >>>>>>>>>>>> > On Tue, May 19, 2009 at 3:41 PM, Chris
> >> >> >> >> >> >>>> >>>>>>>>>>>> > Riccobono
> >> >> >> >> >> >>>> >>>>>>>>>>>> > <crysalim@xxxxxxxxx> wrote:
> >> >> >> >> >> >>>> >>>>>>>>>>>> >>
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> Also I changed 4 of the first 5
> enemies,
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> misleading
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> change
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> notes :P
> >> >> >> >> >> >>>> >>>>>>>>>>>> >>
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> On Tue, May 19, 2009 at 3:38 PM, Chris
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> Riccobono
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> <crysalim@xxxxxxxxx>
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> wrote:
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> > Do you mean it takes a long time to
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> > load?
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >  Because
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> > it
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> > does
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> > that for me
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> > too.  It does work on my system.
>  What
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> > happens
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> > when
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> > you
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> > load it?
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> > On Tue, May 19, 2009 at 3:30 PM, Kent
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> > Petersen
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> > <kentkmp@xxxxxxxxx>
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> > wrote:
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >> Have you tested it? It does not seem
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >> to
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >> work
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >> for
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >> me.
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >> On Tue, May 19, 2009 at 3:22 PM,
> Chris
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >> Riccobono
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >> <crysalim@xxxxxxxxx>
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >> wrote:
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>>
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> I think trying to make the paths
> look
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> more
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> realistic
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> might not be
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> possible, so making them more
> complex
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> so
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> players
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> can't
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> predict them
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> might be the way to go.
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>>
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> On Tue, May 19, 2009 at 3:21 PM,
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> Apache
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> User
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> <dhapache@xxxxxxxxxxxxxxxxxxx>
> wrote:
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> > User:crysalim
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> >
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> > Message: Changes to the paths of
> 3
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> > of
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> > the
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> > first
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> > 4
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> > enemies
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> >
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> > <Files Changed>
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> > U   Scripts/Maps/cavemap.lua
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> >
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> >
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>> >
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>>
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >>
> >> >> >> >> >> >>>> >>>>>>>>>>>> >> >
> >> >> >> >> >> >>>> >>>>>>>>>>>> >>
> >> >> >> >> >> >>>> >>>>>>>>>>>> >
> >> >> >> >> >> >>>> >>>>>>>>>>>> >
> >> >> >> >> >> >>>> >>>>>>>>>>>>
> >> >> >> >> >> >>>> >>>>>>>>>>>
> >> >> >> >> >> >>>> >>>>>>>>>>
> >> >> >> >> >> >>>> >>>>>>>>>
> >> >> >> >> >> >>>> >>>>>>>>
> >> >> >> >> >> >>>> >>>>>>>
> >> >> >> >> >> >>>> >>>>>>
> >> >> >> >> >> >>>> >>>>>
> >> >> >> >> >> >>>> >>>>
> >> >> >> >> >> >>>> >>>
> >> >> >> >> >> >>>> >>
> >> >> >> >> >> >>>> >
> >> >> >> >> >> >>>> >
> >> >> >> >> >> >>>>
> >> >> >> >> >> >>>
> >> >> >> >> >> >>
> >> >> >> >> >> >
> >> >> >> >> >> >
> >> >> >> >> >>
> >> >> >> >> >
> >> >> >> >> >
> >> >> >> >>
> >> >> >> >
> >> >> >> >
> >> >> >>
> >> >> >
> >> >> >
> >> >>
> >> >
> >> >
> >>
> >
> >
>
>

Other related posts: