[openbeosnetteam] Re: Interfaces

  • From: "Axel Dörfler" <axeld@xxxxxxxxxxxxxxxx>
  • To: openbeosnetteam@xxxxxxxxxxxxx
  • Date: Tue, 11 Jul 2006 16:19:49 +0200 CEST

Hi Oliver,

Oliver Tappe <openbeos@xxxxxxxxxxxxxxx> wrote:
> FWIW, here are my ideas:
>       net_interface                 => net_device
>       net_module_interface          => net_interface
>       net_logical_interface         => net_interface_configuration
>       net_logical_interface_private => 
> net_interface_configuration_private
[...]
> I personally don't like 'net_module_interface' very much, as I don't 
> get what 
> the name is trying to tell me. It sounds like the interface of a 
> network 
> module, but it seems to be the interface type handled by the network 
> stack 
> module, right?

It's more or less a cover for the current net_interface structure which 
carries some extra information. While the interface module only sees 
(and maintains) the net_interface, the stack itself only sees the 
net_module_interface.

> Renaming net_logical_interface to net_interface_configuration (or 
> maybe just 
> net_interface_config?) doesn't really help much, but I find it 
> communicates 
> better the fact that it represents an interface instance as 
> configured by 
> means of ifconfig.

You can also see and configure net_interfaces via the AF_LINK family. 
That's how the ethernet MAC address finds its way into ifconfig, btw :-
)
If we rename net_interface to net_device, we should also rename the 
interfaces/ directory to devices/.
Anyway, what about that:
        net_interface                   => net_device
        net_module_interface    => net_device_private or 
net_device_interface
                                                                or 
net_private_device or 
net_internal_device
        net_logical_interface   => net_interface
        "_private                       => "_private

Generally, a net_interface is a net_device bound to a specific domain 
with a specific address.

Bye,
   Axel.


Other related posts: