[muscle] VS: VS: queue undeclared identifier - util/Queue.h

  • From: "David Svanberg" <ds@xxxxxxxxxxx>
  • To: "muscle mailing list" <muscle@xxxxxxxxxxxxx>
  • Date: Wed, 20 Aug 2003 14:47:43 +0200

I did remove "queue" and that compiled -

"if (EnsureSize(GetNumItems()+numItems) != B_NO_ERROR) return B_ERROR;" at
line 511 in MUSCLE 2.43.

/D

-----Opprinnelig melding-----
Fra: muscle-bounce@xxxxxxxxxxxxx [mailto:muscle-bounce@xxxxxxxxxxxxx]På;
vegne av David Svanberg
Sendt: 20. august 2003 11:25
Til: muscle mailing list
Emne: [muscle] VS: queue undeclared identifier - util/Queue.h


Maybe the queue change to _queue isn't the answer - but something is wrong
here.

/D

-----Opprinnelig melding-----
Fra: muscle-bounce@xxxxxxxxxxxxx [mailto:muscle-bounce@xxxxxxxxxxxxx]På;
vegne av David Svanberg
Sendt: 20. august 2003 10:52
Til: muscle mailing list
Emne: [muscle] queue undeclared identifier - util/Queue.h


Lines 501-509 in the util/Queue.h (MUSCLE 2.42) file follows:

template <class ItemType>
status_t
Queue<ItemType>::
AddHead(const ItemType * items, uint32 numItems)
{
   if (EnsureSize(queue.GetNumItems()+numItems) != B_NO_ERROR) return
B_ERROR;
   for (int i=((int)numItems)-1; i>=0; i--) if (AddHead(items[i]) ==
B_ERROR) return B_ERROR;
   return B_NO_ERROR;
}


I think the line "if (EnsureSize(queue.GetNumItems()+numItems) !=
B_NO_ERROR) return B_ERROR;" should be written "if
(EnsureSize(_queue.GetNumItems()+numItems) != B_NO_ERROR) return B_ERROR;".
What do you guys think?

David Svanberg
Software Engineer  Poseidon Simulation AS
Naeringsparken, P.O.Box 89, N-8376 Leknes, Norway
Tel:+47 760 54 330  Fax:+47 760 82 006
E-mail:ds@xxxxxxxxxxx  www.poseidon.no

POSEIDON - your maritime training partner












Other related posts: