[Lugge] Re: problemi con slackware...

  • From: Simone Ravarotto <roger900port@xxxxxxxxx>
  • To: Mailing list LugGe <lugge@xxxxxxxxxxxxx>
  • Date: 09 Feb 2003 14:31:17 +0100

Il dom, 2003-02-09 alle 11:32, Yddu ha scritto:
> Per non riempire di miei (stupide) mail la lista, concentro tutti le mie
> domande e dubbi in una sola mail...:)
> 
> > Non lo carica perchè non c'è :
> > #ls -la cd /lib/modules/'kernelrelease'/kernel/drivers/sound/ | grep es*
> > se l'output e null non hai il modulo necessario.
> 
> 1)non c'è dove?!?:-p
> è una riga che dovrei inserire da qualche parte o è una risposta a qualche
> messaggio?!?!

-fai "man ls" da riga di comando e poi "man grep" e leggi un poco di
documentazione.

ls -la cd /lib/modules/'kernelrelease'/kernel/drivers/sound/ | grep es*

da riga di comando, significa"mostrami se nella directory contenente i
moduli da provare c'è quello che serve per la scheda"
Se il comando non ti restituisce niete significa che i moduli che ti
servono non ci sono per cui è inutili che cerchi di provarli o inserirli
(a grandi linee i comandi modprobe e insmod), oppure che il supporto per
la scheda è/non è compilato nel kernel.

> > Se invece il supporto e' monolitico nel kernel, non è possibile non
> > ascoltare suoni, significherebbe che la scheda è rotta.
> 
> 2)Monolitico?!?!Cioè!?!?
> La scheda non è rotta perchè con eh e mdk funzionava perfettamente...

Cioè non hai compilato il supporto come modulo ma come parte integrante
del kernel, cosa questa che lo rende un poco più pesante.
Hai mai compilato il kernel? 
Manda qui l'output di "lsmod". Vediamo che sta succedendo.

> > Allora se i permessi relativi alle devices dsp* e mixer*
> > sono settati correttamente all'uso da parte degli utenti (a+rw)
> > devi ricompilare il kernel abilitando il supporto alla scheda
> > (se è una soundblaster 128 il modulo è es 1371 , visto che il chipset
> > è un Ensoniq Audiopci 1371 e non 1370)come integrazione o come modulo.
> >
> 3)forse l'ho fatto...insomma nel pannello di controllo (in kde)nella
> gestione del kernel la voce relativa ad ess1371 è attivata come modulo (c'è
> l'ingranaggino...:)) )
>  hai provato ad inserire il modulo sound.o o
> > soundcore.o? Prima di inserire es1371.o ovviamente................
> Si, Giovanni qui dice bene, se hai compilato il supporto per il suono
> come modulo devi mettere prima il modulo relativo e poi quello per la
> scheda e/o chipset, lo potrai trovare nella stessa directory che ho
> scritto nell'altro messaggio ma devi levare la ".o" (scontato, ma non si
> sa mai..)
> 
> 4)lanciando lsmod appare una linea con "soundcore"
> Sulle spiegazioni sui file(?)*.o mi sono completamente perso...cosa dovrei
> levare??dove e a chi?!?!
> scusate la mia infinita ignoranza...
> Yddu

Non ti devi scusare, ma fare "man" ogni volta che puoi, tanto con il
supporto dei teams di traduzione e di Pluto oramai è quasi tutto
tradotto , se hai problemi con l'inglese. 

-- 
Simone Ravarotto <roger900port@xxxxxxxxx>
LugGe

========---------- 
  
 Prima di scrivere in m-list per favore leggi il regolamento 
 http://www.lugge.net/soci/index.php?link=manifesto.htm#list 
 
 Archivio delle e-mail postate in lista 
 http://www.freelists.org/archives/lugge/ 
 
 Modifica dell'account su freelists 
 http://www.freelists.org/cgi-bin/lsg2.cgi  
 
----------======== 
 
 Orari di apertura della sede e come arrivarci: 
 http://www.lugge.net/soci/index.php?link=sede.htm 
  
 
 
  

Other related posts: