[Lugge] Re: Upgrade MDK 8.0 --> MDK 8.2 (Menu di lilo)

  • From: Giuliano <BIPIEFFE@xxxxxxxx>
  • To: lugge@xxxxxxxxxxxxx
  • Date: Wed, 14 Aug 2002 07:16:52 +0200

Andrea,
per quanto riguarda il menu di lilo e tutte quelle voci che mdk fa apparire ogni qual volta che reinstalli od upgradi il so, esse sono il frutto della buona abitudine che linux ha di non compiere atti di violenza e non sovrascrivere o cancellare nulla di ciò che c'è già.
Comunque potresti dare un'occhiata (magari con less) ad /etc/lilo.conf, e verificare dove puntino le label sconosciute.
A questo punto deve esistere la partizione puntata ed allora può esservi un sistema da avviare, oppure no.
Guarda che anche su windows NT, che tu conosci bene, se ripari o reinstalli un'installazione corrotta, nel menu di configurazione del boot loader rimane traccia dell'installazione vecchia, solo diversa da quella di default.
Credo che la cancellazione delle label dal menu di lilo, comunque, non potrebbe fare alcunchè di male al sistema, per due motivi:
quelle corrispondenti all'attuale installazione (che tu intendi utilizzare) vedono un so.
quelle eventualmente rimosse non ne vedono alcuno o, se ne vedessero uno, la loro rimozione non comporterebbe l'automatica rimozione del so corrispondente che, nel caso ti servisse, potresti rimettere in funzione soltanto riscrivendo la label ed il link alla partizione.
Ti saluto e ti abbraccio.
Giuliano


choppoman@xxxxxxxxx wrote:

Ciao a tutti!

Ieri ho provato a fare l'upgrade da Mandrake 8.0 a Mandrake 8.2.

Avendo visto che si poteva fare solo l'upgrade dei pacchetti e non del
sistema in toto ho pensato di provare (sempre x la vecchia faccenda di
gnumeric....  |8-/).

Allora in circa un oretta ho fatto l'upgrade in questione e:

All'avvio il LILO mi fa vedere queste opzioni:

- Failsafe

- Floppy

- Linux

- Linux-2.4.3.mdk

- Linux-nonfb

- old1-windows

- old-linux-nonfb

- windows-0

Ora a parte che io avevo prima solo le opzioni:

- Linux-nonfb

- Windows

Tutto appare andare bene provando a lanciare i vari tipi di Linux...solo
la voce Linux mi fa vedere una schermata grafica e basta.

Guardando l'avvio degli altri linux noto che al momento di montare i
file system appare la voce FALLITO con il seguente errore:

Mount: Tipo FS errato, opzione non valida, superblocco su none
danneggiato o troppi file system montati.

A me pare che tutto funzioni bene ma questo errore mi fa pensare che
l'upgrade non abbia riguardato solo i pacchetti ma anche i file system
da ext2 a ext3 per esempio; inoltre mi sono ritrovato servizi come
apache o samba attivi senza che fossero precedentemente installati.

Allora secondo voi come posso mettere a posto la situazione?

IN particolare vorrei togliere tutti le voci dal menu di avvio di LILO
lasciando solo

- old-linux-nonfb

- old1-windows

ma non trovo più l'utility presente nella 8.0.

Daccordo direte voi posso commentare a mano il LILO.conf ma la mia
preoccupazione è un altra; cosa sono e dove sono piazzate tutte queste
altre versioni? Se le trovo e le elimino rischio un malfunzionamento del
sistema? Come mi devo comportare?

PIccola osservazione:

se nel menu di aggiornamento di una installazione trovo due opzioni:

- aggiorna sistema

- aggiorna solo pacchetti

non trovate antipatico il fatto che siano stati aggiornati e aggiunti
elementi di sistema anche se si è scelto di fare l'upgrade dei soli
pacchetti?

bye

un choppo in ferie....



__________________________________________________
Do You Yahoo!?
HotJobs - Search Thousands of New Jobs
http://www.hotjobs.com
<========----------

Prima di scrivere in m-list per favore leggi il regolamento
http://www.lugge.net/soci/manifesto.htm#list

Archivio delle e-mail postate in lista
http://www.freelists.org/archives/lugge/

----------========>



Other related posts:

  • » [Lugge] Re: Upgrade MDK 8.0 --> MDK 8.2 (Menu di lilo)