[Lugge] Re: Qt...

  • From: Zingus J.Rinkle <1999s039@xxxxxxxxxxxxxxxxxx>
  • To: <lugge@xxxxxxxxxxxxx>
  • Date: Fri, 26 Oct 2001 21:22:26 +0200 (CEST)

---Reply to mail from sergio about [Lugge] Re: Qt...
> Esatto e comi dici te, ma io avevo capito che se le qt sono gi=E0 installate 
> nella distribuzione magari potevano gi=E0 avere il configure.Invece solo le 
> sorgento llo anno giusto?.
OK
> Quindi di conseguenza per compilare le sorgenti vai su root sulla cartella 
> che =E8 stata creata da tar dopodich=E8 digiti ./configure make ed infine se 
> tutto va bene make  install.
Okey Dokey 
> Allora erano gi=E0 installate, quindi ho fatto un link della cartella creando 
> una directory chesi chiamasse qt enon qt2 quindi ora compilando questo 
> programma vede le qt, ma non vede kde, che ho aggiornato.

E qui mi sfugge qualcosa... che errore ti da'?

Perche' se hai bisogno di kde, cio' vuole probabilmente dire che hai
bisogno del pacchetto kdelibs, il che implica (spesso) che se vuoi compilare
per queste librerie, avrai bisogno anche di un pacchetto kdelibs-devel
(o nome simile) che contiene gli include per kdelibs. 

> Sai mica dove viene installato kde?.

Se hai rpm lo puoi scoprire digitando 

rpm -ql kdelibs
e/o
rpm -ql kdebase

che stampano TUTTI i path dei file appartenenti a questi due pacchetti

(per maggiori info su rpm - a parte man rpm - cerca il libro "Maximum RPM"
disponibile in formato digitale, ora mi sfugge l'url, ma se ti interessa
te la mando)

hai cmqe buone prob.ta' che siano in /opt/{kde,kde2} /usr/local/{kde,kde2} 

> Se si' mi saresti di grande aiuto, perche non farei altro che provare un link 
> anche con kde.(sperando che sia giusto quello che sto facendo, a me sembra di 
> si').

I link sono comodi, ma se si esagera ad usarli si va prima o poi incontro
all'errore "too many  levels  of symbolic links" (cosi' lessi), un po'
noioso da eliminare...

In definitiva, scrivimi:
    - che errore ti continua a dare
    - quale fase te lo da' (configurazione o compilazione?)
    - distro che usi (no, aspetta, Mandrake vero?)
    - che programma stai cercando di compilare
    - versione delle qt (non si sa mai, magari e' un bug)
        rpm -q qt

Allora, forse riesco a capire qual'e' la rogna... :-)

Salutoni,
Zingus


<========----------
 Prima di scrivere in m-list per favore leggi il regolamento
 http://lugge.ziobudda.net/benvenuto.html



Other related posts: