[Lugge] Problemi con Apache, cgi, Ruby

  • From: Massimo Arnaudo <marnaudo@xxxxxxxxx>
  • To: Lug Genova <lugge@xxxxxxxxxxxx>
  • Date: Wed, 16 Oct 2002 21:30:03 +0200

Ciao a tutti,
ho un problema: vorrei creare un report tramite html/cgi di una tabella
di Postgres.

Da quello che vedo la procedura si blocca al termine di questo blocco di
codice (viene visualizzato):

#!/usr/local/bin/ruby

require "cgi"
require "postgres"

print "Content-type: text/html\n\n"
print "<html><head>"
print "<title> - trova camera - </title>"
print "</head><body>"
print "<h2>Home yellow pages</h2>"
print "<hr>"

credo che il guaio sia nel blocco seguente:

cgi = CGI.new
h = cgi.params
prov = (h["prov"].to_s).upcase
localita = (h["localita"].to_s).upcase

Sebrerebbe tutto normale...
Dal error log di apache non risulta nulla.

Qualche suggerimento?

I file interi li potrete trovare a:
http://spazioinwind.iol.it/arnaudo/documentazione/Ruby/find_room.html
http://spazioinwind.iol.it/arnaudo/documentazione/Ruby/find_room.rb
-- 
E impari che puoi davvero sopportare,
che sei davvero forte,
e che vali davvero.
---             ---
HomePage:       http://spazioinwind.iol.it/arnaudo
LinuxGroup:     http://lugge.ziobudda.net
========----------
 
 Prima di scrivere in m-list per favore leggi il regolamento
 http://www.lugge.net/soci/manifesto.htm#list

 Archivio delle e-mail postate in lista
 http://www.freelists.org/archives/lugge/

 Modifica dell'account su freelists
 http://www.freelists.org/cgi-bin/lsg2.cgi 

----------========

 La sede e` aperta ogni martedi` pomeriggio 14.30-18.00
 http://www.lugge.net/soci/sede.htm
 


 

Other related posts: