[Lugge] Linux-2.4.18

  • From: giuliano <bipieffe@xxxxxxxx>
  • To: lugge@xxxxxxxxxxxxx
  • Date: Wed, 24 Apr 2002 18:51:22 -0400

Ho tentato di compilare  il kernel in oggetto con gcc-2.96, normalmente
in dotazione a Mandrake e, nonostante il tempo perduto ed elaborazioni
lunghe e faticose, non ci usciva nulla, non veniva creato neppure il
file .config, altro che bzImage!
Ho letto il README allegato al sorgente ed ho visto consigliare
l'impiego di gcc-91.66, sconsigliare gcc-2.92.2 e scartare senza appello
gcc-2.72.3.
Ho ripiegato sulla versione 2.4.16 e, dopo un errore (kernel che si
inchiodava al boot e non c'era verso di farlo andare avanti), sono
riuscito ad avere un'immagine funzionante e, spero un po' meno antiquata
di quella originale Mandrake.
Ci ho rimesso l'automount, ma ci ho guadagnato diverse funzionalità che
desideravo da tempo. Pertanto sono soddisfatto per il momento.
Però mi rode il fatto di avere il sorgente più nuovo e di non poterlo
utilizzare.
Qualcuno saprebbe indicarmi il motivo di questo inconveniente?
Avevo letto qualcosa di compilatori che non compilavano il kernel, ma,
non essendo al momento interessato alla cosa, non ci ho dato importanza
ed ora non so più dove cercare per rileggere quelle note.
L'unica soluzione potrebbe essere quella di installare un gcc che,
almeno dal numero, appare più vecchio?
Ovvero ve ne sono altre?
Dove trovare documentazione se non sulla lista?
Grazie, e buon ponte!
Giuliano


_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com


<========----------
 Prima di scrivere in m-list per favore leggi il regolamento
 http://lugge.ziobudda.net/soci/manifesto.htm#list

 Archivio delle e-mail postate in lista
 http://www.freelists.org/archives/lugge/

----------========>
 Incontri in sede: martedì 15:00-18:00 e sabato 9:30-12.30
 

Other related posts: