[Lugge] Fwd: Re: variabili e altro

  • From: fulvio <fulviopi@xxxxxxxxx>
  • To: lugge@xxxxxxxxxxxxx
  • Date: Mon, 21 Oct 2002 17:24:50 +0200

 vediamo l'output di
 rpm -qa | grep glibc

eccolo:
[root@localhost fulvio]# rpm -qa | grep glibc
glibc-devel-2.2.5-16mdk
glibc-2.2.5-16mdk


 vediamo anche il resto
 rpm -qa | grep atk

ecco:
[root@localhost fulvio]# rpm -qa | grep atk
libatk1.0_0-1.0.3-2mdk

> cerco allora il file pango.pc per modificare la variabile
> PKG_CONFIG_PATH, ma non lo trovo.
> [root@localhost fulvio]# locate pango.pc
> [root@localhost fulvio]#

 Ue` senti bello ti va di scherzare?
 updatedb; locate pango.pc

 oppure

 rpm -ql $(rpm -qa | grep pango) | grep -e "pango.pc"

 poi siamo sicuri che sia pango.pc e non pango.rc, errore di stompa di un
 programmatore?

 rpmnet dice che non esistono pacchetti che contengono il file pango.pc
 http://rpmfind.net/linux/rpm2html/search.php?query=pango%2Epc

grazie per il consiglio (e per il "... bello") e peccato per l'opinione di 
rpmnet 
[root@localhost fulvio]# updatedb; locate pango.pc
/home/fulvio/pango-1.0.4/pango.pc.in
/home/fulvio/pango-1.0.4/pango.pc
/home/fulvio/pango-1.0.5/pango.pc.in

> Provo allora ad installare il pacchetto  pango-1.0.4-1mdk.i586.rpm con
>
> urpmi pango-1.0.4-1mdk.i586.rpm
>
> ma ottengo:
> [root@localhost fulvio]# urpmi pango-1.0.4-1mdk.i586.rpm
> problema nel leggere il file synthesis del supporto "disc 1 Download
> Edition - Installation CD (x86) (cdrom1)"
> problema nel leggere il file synthesis del supporto "disc 2 Download
> Edition - Second Installation CD (x86) (cdrom2)"
> problema nel leggere il file synthesis del supporto "disc 3
> Supplementary Applications CD (x86) (cdrom3)"
> tutto già installato

 <Daniele dico a te e al tuo apt-get>
 gioia se elimini/sposti/incasini i files di DB che servono a urpmi per
 fuzionare c'e ben poco da criticare. </Daniele dico a te e al tuo apt-get>

cerco di interpretare: pensi che io abbia eliminato/spostato/incasinato i  
files di DB che servono a urpmi per fuzionare? se si come posso verificarlo 
ed eventualmente riparare?

 rpm -ivh (nome_file)

 nome_file:pango-1.0.4-1mdk.i586.rpm

 rpm -e (nome_pacchetto)

 nome_pacchetto:

 pango
 pango-1.0.4-1mdk

 MA NON e` uguale al nome del file:

 pango-1.0.4-1mdk.i586.rpm

ora è chiaro!

In conclusione un passo avanti verso il mio obiettivo (l'installazione di 
gtk+-2.0.2) l'ho fatto, ho trovato il mitico pango.pc e ho aggiustato 
conseguentemente PKG_CONFIG_PATH, infine fiducioso:

[root@localhost gtk+-2.0.2]# ./configure
...
checking for glib-2.0 >= 2.0.1 atk >= 1.0.1 pango >= 1.0.1... yes 
(RIPETO: YES!)
...
checking for jpeg_destroy_decompress in -ljpeg... no
configure: warning: *** JPEG loader will not be built (JPEG library not found) 
***
configure: error:
*** Checks for JPEG loader failed. You can build without it by passing
*** --without-libjpeg to configure but some programs using GTK+ may
*** not work properly

E ORA COS'ALTRO VUOLE?

Un saluto
Fulvio

P.S.
ho cercato tra i pacchetti installati ed ho trovato libjpeg62 ver. 6b-25mdk
c'entra qualche cosa?
========----------
 
 Prima di scrivere in m-list per favore leggi il regolamento
 http://www.lugge.net/soci/manifesto.htm#list

 Archivio delle e-mail postate in lista
 http://www.freelists.org/archives/lugge/

 Modifica dell'account su freelists
 http://www.freelists.org/cgi-bin/lsg2.cgi 

----------========

 La sede e` aperta ogni martedi` pomeriggio 14.30-18.00
 http://www.lugge.net/soci/sede.htm
 


 

Other related posts: