[Lugge] Aiuto su Kppp

  • From: <maurizio.colella@xxxxxx>
  • To: <lugge@xxxxxxxxxxxxx>
  • Date: Wed, 19 Jan 2005 09:21:54 -0000

Ciao,
.. scusatemi se scrivo strafalcioni...
Possiedo un laptop Dell sul quale ho installato Debian Bf24..
Il Pc e' dotato di un modem integrato: PCTEL 2304WC.
Ho scaricato ed installato il binario pctel-0.9.7-9.tar.gz.
Ho poi installato i 2 moduli pctel e ptserial con "insmod -f".
Il comando restituisce un warning circa il fatto che i moduli sono stati creati 
per il kernel 2.4.18-1-386 anziche' il 2.4.18-bf2.4.. ma di fatto i moduli 
rilevano un device PCTel sul /dev/ttyS1, come conferma anche la fine del 
"dmesg".
Lanciato minicom sul /dev/ttyS15, attraverso i comandi classici AT, riesco ad 
operare col modem in maniera corretta, senza alcun problema.
Configurato un profilo ISP con "pppconfig", e successivamente lanciato con "pon 
<profilo-ISP>, il pc si collega ad internet e naviga senza problemi.
Ho aggiunto i due moduli nel file /etc/modules per rilevare la periferica gia' 
dal boot, ma haime' cio' non avviene (.. forse perche' /etc/modules non vuole 
"forzare" alcun modulo ?).. Al momento ho 2 problemi che non so  come risolvere:
1) .. caricare i moduli al boot evitando l'uso di uno script (che rimane 
comunque una alternativa percorribile, ma meno elegante)
2) .. Dire a Kppp che esiste un /dev/ttyS15, poiche' nella lista dei device da 
scegliere non appare il /dev/ttyS15 (si ferma al /dev/ttyS4 !).
qualsiasi commento/suggerimento e' ben gradito.
Grazie anticipatamente al vostro contributo.
Maury



========----------

 Archivio delle e-mail postate in lista
 http://www.freelists.org/archives/lugge/

 Prima di scrivere in m-list per favore leggi il regolamento
 http://www.lugge.net/index.php?mod=cosa_facciamo/gruppo_di_discussione

 Modifica dell'account sulla lista LUGGe
 http://www.lugge.net/index.php?mod=cosa_facciamo/gruppo_di_discussione#list



Other related posts: