[jhb_airlines] Re: Autopilot APPR HOLD problem

  • From: "Bones" <bones@xxxxxxx>
  • To: <jhb_airlines@xxxxxxxxxxxxx>
  • Date: Sun, 16 Oct 2005 05:16:02 +0100

What a strange panel.

I remember it now, one of many I've tried and dumped in the past. This one
proves that if you have a very good panel for an aircraft you think the
aircraft itself flies nicely and if you have a bad panel the aircraft is
rubbish. I had no problems with the Citation at all until I attached this
panel to it. I've flown it around for a couple of hours now and didn't enjoy
much of it at all.

The panel itself is a strange mixture of good and bad. It's got a lot of GAU
files but there are several XML's in there too. What I don't understand is
that one of the XML CAB files it uses has 84 switches in it (including all
the autopilot functions) but he's only borrowing two switches from this file
and ignoring the rest. The autopilot switches he has chosen are separate GAU
files and are not quite standard - they do slightly odd things.

The APPR button worked for me, both on the GF unit and selecting it on the
aircraft panel. The Speed button seems OK'ish too but it's a cobbled thing -
it acts as both AP_AUTOTHROTTLE engage and AP_IAS_HOLD in one unit. No
separate Autothrottle arming switch. Bad news is that it sometimes doesn't
disengage when you deselect it and it's usually too late when you find this
out.

Other oddities are the GPU/APU as the aircraft is BAT start or GPU only. In
fact you can start this aircraft without using the APU at all so it's only
there for show. Bottom left switches work OK but the labels are very poor on
the bottom row.

It's a very messy layout which leaves you hunting all over the place for
familiar switches and dials. Some dials (like RAD ALT and ELEV TRIM) are
huge whilst other essential instruments are far too small to be read easily.
Some dials are quite sophisticated, like the standby horizon and other
border on the crude - the ALT SEL thing on the panel looks like a rubber
grommet to me.

Flying tests proved something of a trial as I was trying to understand
aircraft responses as well as hunt around this panel for data. I found
faults with both the aircraft and the panel though. Aircraft first...

This isn't a jumbo - it's a very nippy little jet - so you have to revise
your thinking about climbout procedures. Set about +60 trim and apply full
throttle. When you hit 100kts pull the nose up to 25 degrees on the horizon
(I can tell you this doesn't feel natural as you think you will stall but
PULL THAT STICK BACK!). Get the gear up (don't use flaps) and trim for 25
degrees. At this pitch the aircraft will settle into an 1800fpm climb at
around 150kts. Keep checking the nose and don't let it drop until you have
the AP set up and on. Don't forget that the C550 doesn't have any slats or
other fancy lift devices that add both lift AND drag to the bigger jets so
it is going to take off like a scalded cat. You have to contain this.

Round for the first ILS and the APPR mode captured the ILS first time. The
approach seemed normal until about 4nm out and then the aircraft just
dropped off the glideslope and started a rapid sink earthwards. This was at
120kts so it was well above stall so I climbed away for some handling. In
manual flight it would happily fly round at 100kts flaps up without batting
an eyelid and a little bit slower with flaps down. Get below these speeds
though and the drag rises rapidly - if you check a slight loss of height by
pulling the stick back even very slightly the speed winds off very fast
indeed. I flew 100kt circuits without any problem at all so I tried a second
ILS. Again the thing was fine at more than 120kts but as soon as I brought
it even one knot lower it quit the glideslope capture. I've seen other
aircraft do this too so I'm not sure what is going on. I'll try the ILS on
the normal panel I use and see if it is any different. I could be panel
related or it may be a drag/autothrottle mismatch.

Just after that it locked up my GF_MCP readouts totally - although the dials
still worked.

Differential roll I have sorted out. The aircraft still has an FS2002 .air
file and it's missing quite few entries for FS2004. As soon as I entered
values for tables 342 and 518 it started to behave properly. I'll do the
same for elevator and rudder next.

Actually I won't go on any more as I'll just rip the panel to pieces and it
doesn't really deserve it. Some bits are very good but they are spoiled by
tacky, mickey mouse dials alongside. The engine gauges are good (a pity you
can see the sky behind them as he hasn't quite got the fit right) as are the
annunciator lights above. The main EHSI is too small, too cluttered and very
bad to read. The autopilot switches are all over the place (the original
isn't too good either but it's not THAT bad). A good rebuild might see it
much improved but that would be a reasonably long job.

I just tried an ILS with a second panel and the same drop below the ILS
happened when speed got below 121 kts so it must be an automatic decouple
for some reason. It's usual for this to happen near the stall but this is
excessive for this aircraft. Daft thing is that you can switch off the
autopilot and fly quite happily manually for the rest of the approach..

Must investigate further.

bones

-----Original Message-----
From: jhb_airlines-bounce@xxxxxxxxxxxxx
[mailto:jhb_airlines-bounce@xxxxxxxxxxxxx] On Behalf Of Mike Lucas
Sent: 15 October 2005 16:57
To: jhb_airlines@xxxxxxxxxxxxx
Subject: [jhb_airlines] Re: Autopilot APPR HOLD problem


Thanks for the offer, John.  Remember that I use FS2002 so it could be
that the panel (cessna_citation_ii_v2.zip from Avsim) - which is listed
for FS2004 - won't work properly with FS2002.  Having said that, the
aircraft itself is listed as FS2004 but it seems fine in FS2002.

Mike L

Bones wrote:
> Give me the name of this panel and I'll download it and have a hunt
> around. If the autopilot is an XML file I should be able to track down
> why the APPR button isn't working. OTOH if it's and old GAU file then
> that's beyond my abilities as I have no C++ skills.
>
> I've built an autopilot for the Aztec and the code is very simple. An
> APPR button isn't very hard to do so I could probably add this to the
> Citation if the original is faulty.
>
> bones
>
> -----Original Message-----
> From: jhb_airlines-bounce@xxxxxxxxxxxxx
> [mailto:jhb_airlines-bounce@xxxxxxxxxxxxx] On Behalf Of Mike Lucas
> Sent: 15 October 2005 12:48
> To: jhb_airlines@xxxxxxxxxxxxx
> Subject: [jhb_airlines] Re: Autopilot APPR HOLD problem
>
>
> bones
>
> Thanks for this info, and your other reply on gauge design.  I have no
> desire to enter a minefield ....
>
> I may try a different panel with the Citation and see if I can get
> APPR_HOLD to work.
>
> Think I've got the AP autothrottle and IAS hold sussed now ... <g>
>
> Mike L
>
> Bones wrote:
>
>>You are walking into a minefield here Mike so it may be best to leave
>>well alone. I don't know anything about the panel you got for the C550
>>but it would need a much closer look at the gauges supplied to see
>>what was included in the package and what was not.
>>
>>The gauge line you quote doesn't mean a lot to me as I don't have a
>>fsd_generic.ap.appr.gau (it could be a CAB file too). It becomes
>>tricky because just because the line is in the panel.cfg file it
>>doesn't automatically mean the gauge itself is in your gauges folder.
>>Although likely I can't even say this is an APPR hold function either.
>>It's unusual if it is because ALL the autopilot functions are normally
>>contained in a single autopilot gauge.
>>
>>The FS command AP_IAS_HOLD is a different beast to AP_AUTOTHROTTLE. If
>>you set a P8 button for the latter then (assuming the aircraft is
>>fitted with an AP and AT in the aircraft.cfg file) you have access to
>>speed control - it is, effectively, the Autothrottle Arm function.
>>
>>The AP_IAS_HOLD function is the same as the IAS button on the
>>autopilot panel on most aircraft. This is an engage/disengage button
>>but it has no effect if the Autothrottle isn't armed in the first
>>place. You don't need to allocate this button to a P8 switch because
>>it should already be programmed into the HOLD button below the
>>IAS/Mach rotary switch on your MCP. It's the same as the NAV and HDG
>>hold buttons alongside - press to engage or disengage.
>>
>>So, what you should really have is the AP_IAS_HOLD command set to the
>>HOLD button below the IAS/Mach panel on the MCP. On the P8 you
>>allocate a button for the AP_AUTOTHROTTLE function. When flying the
>>aircraft you hit the P8 to arm the autothrottle, dial in a speed you
>>want and then press the HOLD button to engage.
>>
>>You can mostly ignore the reference speeds in the aircraft.cfg as they
>>are only used in one of the FS menus - I think Weight and Balance.
>>They have absolutely no effect on the sim itself. The speeds are
>>actually the wrong way round but they are correct - the Citation has a
>>very low stall speed. It was intentionally designed for slow flight as
>>it gave the aircraft the ability to operate out of very short strips -
>>something no other jet is capable of. It was an impressive feat by
>>Cessna as the aircraft doesn't have any complex wing devices at all,
>>but there again it is quite a light aircraft.
>>
>>What is good about the Citation is that at 100kts the aircraft still
>>has excellent roll rate. It is a very nice aircraft indeed for a pilot
>>and doesn't really deserve its "toy jet" title from the Lear/Falcon
>>brigade.
>>
>>bones
>>
>>
>>-----Original Message-----
>>From: jhb_airlines-bounce@xxxxxxxxxxxxx
>>[mailto:jhb_airlines-bounce@xxxxxxxxxxxxx] On Behalf Of Mike Lucas
>>Sent: 14 October 2005 19:29
>>To: jhb_airlines@xxxxxxxxxxxxx
>>Subject: [jhb_airlines] Re: Autopilot APPR HOLD problem
>>
>>
>>bones
>>
>>I'm afraid I don't know what it is I'm looking for in the panel and
>>aircraft.cfg files ...
>>
>>Panel.cfg contains the line -
>>
>>gauge37=fsd_generic.ap.appr,  213,517,20,23
>>
>>which suggests to me that there should be a working APPR_HOLD
>>function.
>>
>>As regards the GoFlight autothrottle, I have disabled the "arm when
>>CMD is activated" option.  But I cannot get the IAS/Mach hold to work
>>from a P8 button.  The appropriate P8 light comes on but it doesn't
>>activate the IAS/Mach hold (yes, I have designated the correct
>>function in GF config).  I can only get IAS/Mach hold to work using
>>Ctrl+R.  Any ideas??
>>
>>Going back to the Cessna Citation specifically, I found the following
>>in aircraft.cfg -
>>
>>[Reference Speeds]
>>flaps_up_stall_speed=77.0      //Knots True (KTAS)
>>full_flaps_stall_speed=80.0    //Knots True (KTAS)
>>cruise_speed=262.0              //Knots True (KTAS)
>>max_indicated_speed=350.453125
>>max_mach=0.75
>>
>>Surely flaps up stall speed should be higher than full flaps stall
>>speed?? - and I would have expected both to be 100+ kts.
>>
>>Confused.
>>
>>Mike L
>>
>>Bones wrote:
>>
>>
>>>First thing to suspect is the panel because it suggests the autopilot
>>>gauge it uses may not be working properly. If it works in other
>>>aircraft but not the C550 then it may be the interaction between the
>>>panel and the aircraft.cfg file. In my copy both the autopilot and
>>>autothrottle are flagged as available.
>>>
>>>Check the MCP options in the GF Module. You should have two radio
>>>buttons which enable/disable autothrottle with AP activation. I don't
>>>actually use this myself as there are times when I want to keep AT
>>>active when flying manually and so I have one of the T8 switches set
>>>for AT engage/disengage. This works perfectly well. The command you
>>>want is called AP_AUTOTHROTTLE.
>>>
>>>bones
>>>
>>>-----Original Message-----
>>>From: jhb_airlines-bounce@xxxxxxxxxxxxx
>>>[mailto:jhb_airlines-bounce@xxxxxxxxxxxxx] On Behalf Of Mike Lucas
>>>Sent: 14 October 2005 16:09
>>>To: jhb_airlines@xxxxxxxxxxxxx
>>>Subject: [jhb_airlines] Autopilot APPR HOLD problem
>>>
>>>
>>>For one sector of my FPI session on Wed evening I flew the Cessna
>>>Citation by VENEAVIONES in JHB livery, with panel by Brian Williams.
>>>Unfortunately, I discovered that APPR HOLD didn't work (at EGTE).
>>>Can someone with more expertise than me in this area tell me if this
>>>is a problem somewhere in one of the config files (aircraft.cfg or
>>>panel.cfg?) that can be easily fixed?
>>>
>>>Still coming to terms with the new GoFlight autopilot module, in
>>>particular the apparent lack of an autothrottle arm switch.  Only an
>>>IAS/Mach Hold and although I have configured one of my P8 buttons as
>>>A/Thr Arm it doesn't seem to activate and I have to resort to Ctr+R -
>>>which rather defeats the purpose of this all-singing, all-dancing
>>>autopilot module (I can even get BBC2 on it .... <g>)
>>>
>>>Mike L
>>>
>>>
>>>
>>
>>
>>
>>
>
>
>



Other related posts: