[jala-dev] another suggestion for jala.Form

  • From: <tobias.schaefer@xxxxxx>
  • To: <jala-dev@xxxxxxxxxxxxx>
  • Date: Thu, 3 May 2007 14:34:16 +0200

hi again

i would like to suggest another change in jala.Form, regarding the 

1. the name of the component defines the actual skin/subskin
2. the source property is optional (i'd even say obsolete)

example (with the current naming):

   "class": "SkinComponent",
   name: "foo#bar"

the reason: personally, i try to keep scripting code clear from html with 
never-ending effort. i think that's best practice and what helma has taught me 
so far. 

thus, currently my skin component code looks like this:

   "class": "SkinComponent",
   source: '<% foo.skin name="foo#bar" %>

ie. the code always needs to go the detour of creating and rendering the source 
property as skin just for the sake of rendering the skin defined by the macro 
inside of it.

i'd appreciate if the SkinComponent would support and reward such honorable 

what do you think?


Other related posts:

  • » [jala-dev] another suggestion for jala.Form