[jala-dev] Further feedback on jala.Form

  • From: <tobias.schaefer@xxxxxx>
  • To: <jala-dev@xxxxxxxxxxxxx>
  • Date: Thu, 10 May 2007 13:33:51 +0200

Hello again

First of all congratulations to the improved version of jala.Form; it's much 
more convenient now (at least for me :)

I made some further observations I'd like to share with you:

 1. I noticed that it's the "require()" method vs the "required" declaration; 
no tragedy, but in the first place I entered "require" in the form object 
structure. maybe, you could indeed rename the latter to "required"?

 2. The exclamation marks in the default error messages are a little bit bossy 
(the old shouting thing). Thus, I always would want to overwrite the default 
messages with the corresponding method or declaration to be nice to the users 
of my app. If we'd drop the exclamation marks I could spare me this extra work. 
Furthermore, the wording of the messages themselves could need some 
elaboration, generally. (If I only could find them more easily in the code...)

 3. In the application I am testing jala.Form right now I have just a few 
generic HopObject properties and quite a lot of XML-encoded ones (ie. using 
PropertyMgr). Thus, I need to set custom setter/getter methods to almost every 
form component. It would be helpful if I could define default methods for the 
whole form object and thus, simply override these with component-specific ones.

Finally, I still think we need to find better names for the following methods / 
properties, and this time I provide some proposals:

 * setDataObj - what about "setSource"? or at least: "setDataObject"?
 * submitCaption - why not simply "label", just as for components? (Just for a 
reason to rename this: "A caption is a concise and descriptive bit of text that 
labels a picture, chart, or table", says Wikipedia. The submit button doesn't 
have a caption IMHO but it is labeled or named.)


Other related posts: