[hawkmoth] [PATCH] hawkmoth: remove unused deprecated import

  • From: Bruno Santos <brunomanuelsantos@xxxxxxxxxxxxxxxxxx>
  • To: hawkmoth mailing list <hawkmoth@xxxxxxxxxxxxx>
  • Date: Sat, 20 Apr 2019 23:34:57 +0200

This trivial bit of cleaning up was left over from an earlier commit:

        1252995a872f2cf115ff26a58a576682514e16f9
        cautodoc: drop usage of deprecated AutodocReporter

Deleting the code that used AutodocReporter made the deprecation warning
go away and so the import line was forgotten. Now the latest Sphinx
finally removes this interface altogether resulting in a crash on
import.

Fixes issue #6.
---
 hawkmoth/__init__.py | 1 -
 1 file changed, 1 deletion(-)

diff --git a/hawkmoth/__init__.py b/hawkmoth/__init__.py
index 79062f6..7913014 100644
--- a/hawkmoth/__init__.py
+++ b/hawkmoth/__init__.py
@@ -17,7 +17,6 @@
 from docutils import nodes, statemachine
 from docutils.parsers.rst import directives, Directive
 from docutils.statemachine import ViewList
-from sphinx.ext.autodoc import AutodocReporter
 from sphinx.util.nodes import nested_parse_with_titles
 from sphinx.util.docutils import switch_source_input
 
-- 
2.21.0


Other related posts: