[openbeos] makehdimage errors

  • From: Nathan Sandver <nsandver@xxxxxxxxx>
  • To: openbeos@xxxxxxxxxxxxx
  • Date: Tue, 2 Aug 2005 22:33:19 -0700

Hello,

I tried to build Haiku tonight on a fresh install of BeOS R5 Pro with
build tools installed according to instructions I found at:

http://darkwyrm.beemulated.net/haiku/HOWTO-Get-Haiku.htm

I guess I should first ask whether there's anything lacking in those
instructions. Assuming those are okay, I updated my source from the
subversion repository, ran configure, and then ran makehdimage. That
ran for a while, then I started seeing tons of linking errors, but I
was doing other things during the compile, so maybe the problem
started earlier. Anyway, after makehdimage finished running, I tried
running it again just for the hell of it, and the output below is from
that second run.

Here's the messages I got from makehdimage:

$ makehdimage /Haiku/
Building binaries and copying them to /Haiku/
Building executables and libraries...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...patience...
...found 27685 target(s)...
...updating 2666 target(s)...
Yacc1 objects/x86.R1/bin/bash/parse.c objects/x86.R1/bin/bash/parse.h
Cc objects/x86.R1/bin/bash/print_cmd.o
conflicts:  1 shift/reduce
YaccMv objects/x86.R1/bin/bash/parse.c objects/x86.R1/bin/bash/parse.h
Cc objects/x86.R1/bin/bash/parse.o
Cc objects/x86.R1/bin/bash/execute_cmd.o
Link distro/x86.R1/beos/bin/sh
XRes1 distro/x86.R1/beos/bin/sh
Chmod1 distro/x86.R1/beos/bin/sh
SetType distro/x86.R1/beos/bin/sh
MimeSet distro/x86.R1/beos/bin/sh
SetVersion distro/x86.R1/beos/bin/sh
...updated 6 target(s)...
Link distro/x86.R1/beos/bin/strace
/boot/develop/tools/gnupro/i586-pc-beos/bin/ld:
objects/x86.R1/bin/strace/TypeHandler.o: bad reloc symbol index
(0x400044 >= 0xc3) for offset 0xf in section
`.gnu.linkonce.t._._t15TypeHandlerImpl1Zx'
objects/x86.R1/bin/strace/TypeHandler.o: could not read symbols: Bad value
collect2: ld returned 1 exit status

        gcc -Xlinker -soname=_APP_ -o "distro/x86.R1/beos/bin/strace" 
"objects/x86.R1/bin/strace/strace.o"
"objects/x86.R1/bin/strace/MemoryReader.o"
"objects/x86.R1/bin/strace/TypeHandler.o"
"objects/x86.R1/bin/strace/strace_syscalls0.o"
"objects/x86.R1/bin/strace/strace_syscalls1.o"
"objects/x86.R1/bin/strace/strace_syscalls2.o"
"objects/x86.R1/bin/strace/strace_syscalls3.o"
"objects/x86.R1/bin/strace/strace_syscalls4.o"
"objects/x86.R1/bin/strace/strace_syscalls5.o"
"objects/x86.R1/bin/strace/strace_syscalls6.o"
"objects/x86.R1/bin/strace/strace_syscalls7.o"
"objects/x86.R1/bin/strace/strace_syscalls8.o"
"objects/x86.R1/bin/strace/strace_syscalls9.o"
"objects/x86.R1/bin/strace/strace_syscalls10.o"
"objects/x86.R1/bin/strace/strace_syscalls11.o"
"objects/x86.R1/bin/strace/strace_syscalls12.o"
"objects/x86.R1/bin/strace/strace_syscalls13.o"
"objects/x86.R1/bin/strace/strace_syscalls14.o"
"objects/x86.R1/bin/strace/strace_syscalls15.o"
"objects/x86.R1/bin/strace/strace_syscalls16.o"
"objects/x86.R1/bin/strace/strace_syscalls17.o"
"objects/x86.R1/bin/strace/strace_syscalls18.o"
"objects/x86.R1/bin/strace/strace_syscalls19.o"
"objects/x86.R1/system/libroot.so"
"distro/x86.R1/beos/system/lib/libstdc++.r4.so"  ;

...failed Link distro/x86.R1/beos/bin/strace ...
...failed updating 1 target(s)...
Link distro/x86.R1/beos/bin/rmdir
gcc: objects/x86.R1/bin/coreutils/src/rmdir.o: No such file or directory

        gcc -Xlinker -soname=_APP_ -o "distro/x86.R1/beos/bin/rmdir" 
"objects/x86.R1/bin/coreutils/src/rmdir.o"
"objects/x86.R1/bin/coreutils/lib/libfetish.a"  ;

...failed Link distro/x86.R1/beos/bin/rmdir ...
...failed updating 1 target(s)...
Link distro/x86.R1/beos/bin/error
gcc: objects/x86.R1/bin/error.o: No such file or directory

        gcc -Xlinker -soname=_APP_ -o "distro/x86.R1/beos/bin/error" 
"objects/x86.R1/bin/error.o" "objects/x86.R1/system/libroot.so"  ;

...failed Link distro/x86.R1/beos/bin/error ...
...failed updating 1 target(s)...
Link distro/x86.R1/beos/bin/ifconfig
gcc: objects/x86.R1/bin/ifconfig/ifconfig.o: No such file or directory

        gcc -Xlinker -soname=_APP_ -o
"distro/x86.R1/beos/bin/ifconfig" 
"objects/x86.R1/bin/ifconfig/ifconfig.o"
"distro/x86.R1/beos/system/lib/libsocket.so"
"distro/x86.R1/beos/system/lib/libbind.so"  ;

...failed Link distro/x86.R1/beos/bin/ifconfig ...
...failed updating 1 target(s)...
Link distro/x86.R1/beos/bin/ping
gcc: objects/x86.R1/bin/ping/ping.o: No such file or directory

        gcc -Xlinker -soname=_APP_ -o "distro/x86.R1/beos/bin/ping" 
"objects/x86.R1/bin/ping/ping.o"
"distro/x86.R1/beos/system/lib/libsocket.so"
"distro/x86.R1/beos/system/lib/libbind.so"
"objects/x86.R1/system/libroot.so"  ;

...failed Link distro/x86.R1/beos/bin/ping ...
...failed updating 1 target(s)...
Link distro/x86.R1/beos/bin/traceroute
gcc: objects/x86.R1/bin/traceroute/traceroute.o: No such file or directory

        gcc -Xlinker -soname=_APP_ -o
"distro/x86.R1/beos/bin/traceroute" 
"objects/x86.R1/bin/traceroute/traceroute.o"
"distro/x86.R1/beos/system/lib/libsocket.so"
"distro/x86.R1/beos/system/lib/libbind.so"
"objects/x86.R1/system/libroot.so"  ;

...failed Link distro/x86.R1/beos/bin/traceroute ...
...failed updating 1 target(s)...
Link distro/x86.R1/beos/bin/arp
gcc: objects/x86.R1/bin/arp/arp.o: No such file or directory

        gcc -Xlinker -soname=_APP_ -o "distro/x86.R1/beos/bin/arp" 
"objects/x86.R1/bin/arp/arp.o"
"distro/x86.R1/beos/system/lib/libsocket.so"
"distro/x86.R1/beos/system/lib/libbind.so"
"objects/x86.R1/system/libroot.so"  ;

...failed Link distro/x86.R1/beos/bin/arp ...
...failed updating 1 target(s)...
Link distro/x86.R1/beos/bin/pppconfig
gcc: objects/x86.R1/bin/pppconfig/pppconfig.o: No such file or directory
gcc: objects/x86.R1/add-ons/kernel/network/ppp/shared/libppp/libppp.a:
No such file or directory

The error messages just go on and on from here, lots of similar
errors. If I need to supply more information, please let me know what
I can do to be more helpful.

Thanks, 

-- 
Nathan Sandver <nsandver@xxxxxxxxx>

Other related posts: