[haiku] Re: NetHack for BeOS to be deprecated!

  • From: François Revol <revol@xxxxxxx>
  • To: haiku@xxxxxxxxxxxxx, Liam Proven <lproven@xxxxxxxxx>
  • Date: Tue, 1 May 2018 22:36:14 +0200

Hi Liam,

Le 01/05/2018 à 22:13, Liam Proven a écrit :

Anyone want to step up to maintain the port?

https://www.nethack.org/devel/deprecation.html

Thanks for the headsup.
AFAIK nobody uses BeOS anymore.

I didn't check what was required to support BeOS, but most hacks from
the era are not required for Haiku, so the BeOS stuff can likely be
cleaned up.

We seem to have a Haiku port already, with a few patches:

https://github.com/haikuports/haikuports/tree/master/games-roguelike/nethack

Hopefully someone can upstream this.

We still require C89 (gcc2.95) for the primary arch due to the BeOS
binary compatibility, but as it's not a library it should be possible to
compile it with latest GCC without trouble.



As for Amiga and Atari, I know a few people still using those platforms,
FWIW they now have mostly up-to-date toolchains with recent GCC thanks
to NetSurf:
http://git.netsurf-browser.org/toolchains.git/

So possibly it should still be possible to support those platforms
without keeping old syntax around.


François.

Other related posts: