[openbeos] Re: Coding Suggestion -- Templates, Iterators

  • From: "Mikael J." <tic_khr@xxxxxxxx>
  • To: openbeos@xxxxxxxxxxxxx
  • Date: Fri, 18 Jan 2002 15:33:50 +0100

>
>Bill has it right that both the containter type and the iterator should 

>be typedef'd -- that was just laziness on my part only doing the 
>iterator. I would agree with most of what Bill said except for the part 

>about short names. Short names are wonderful and readable. Nobody is 
>ever going to convince me that
>
>int
>maxElement (int array[], int size)
>       {
>       int loopIndex;
>       int maximumValue = a[0];
>
>       for (loopIndex = 1; loopIndex< size; ++loopIndex)
>               if (array[loopIndex] > maximumValue)
>                       maximumValue = array[loopIndex];
>
>       return maximumValue;
>       }
>
That depends on if you're a VisualBasic coder or not.

--
Mikael J @ http://hem.spray.se/tic_khr


Sorry, couldn't resist. :D



 

Other related posts: