[haiku-development] Re: server/daemon

  • From: Ryan Leavengood <leavengood@xxxxxxxxx>
  • To: haiku-development@xxxxxxxxxxxxx
  • Date: Mon, 5 Apr 2010 15:06:37 -0400

2010/4/3 Jonas Sundström <jonas@xxxxxxxxxxx>:
> I know this is a superficial issue, but wouldn't it be a
> good thing to standardize on either "_server" or "_daemon"?
> (or even "_service") To make Haiku even easier to understand.

In general I would agree with consistency, but renaming some of the
daemons might not make sense, as I'll explain below.

> Is there currently any practical distinction between these
> two kinds?

Thinking about the mail_daemon and the cddb_daemon, renaming them to
mail_server and cddb_server might be confusing, as users might think
they are internet-like servers which serve mail and CDDB information,
when really they are just background processes which fetch mail and
CDDB information. If we should rename them it should be to
mail_fetcher and cddb_fetcher or something similar. The syslog_daemon
can be changed to syslog_server without a problem in my opinion.


Other related posts: