[haiku-development] Re: [patch] Show partition types in DriveSetup

  • From: José Manuel <jmfo1982@xxxxxxxxx>
  • To: haiku-development@xxxxxxxxxxxxx
  • Date: Tue, 17 Apr 2012 14:31:23 +0200

2012/4/17, Axel Dörfler <axeld@xxxxxxxxxxxxxxxx>:
> On 16.04.2012 20:59, Ingo Weinhold wrote:
>> I suspect for a lot of topics raised on this mailing list, you find a lot
>> of people who are not interested in it. :-)
>
> Besides that, discussing an early work in progress, or for a general
> direction (even with a patch) is much better done on the mailing list.
> One can always just paste the patch within the mail so that it's not lost.
> That said, if persistence is an aim, the bug tracker is indeed the
> better choice.
>
>>>   BString partitionType = BString("(");
>>>   partitionType<<  partition->Type()<<  ")";
>> I like the single line version better.
>
> +1
>
>>> or better yet:
>>>   BString partitionType = BString(partition->Type());
>>>   partitionType.Prepend("(");
>>>   partitionType.Append(")");
>> That reduces the readability IMO. Using SetToFormat() would also be an
>> alternative with good readability.
>
> +1
> The single line version is perfectly clear, no reason to split that up
> into three lines -- that's not only less efficient, it's also not as
> clear IMO.

Okay, then taking into account the most liked version, the changes would be:

        BString partitionType = BString("(");
        partitionType << partition->Type() << ")";
        SetField(new BStringField(partitionType), kFilesystemColumn);

Is this the proper spacing?

Regards,
José Manuel

Other related posts: