[haiku-development] Re: "media-plugin" naming convention (wasRe: Donating codes: APE reader)

  • From: "Axel Dörfler" <axeld@xxxxxxxxxxxxxxxx>
  • To: haiku-development@xxxxxxxxxxxxx
  • Date: Thu, 05 Jun 2008 21:32:31 +0200 CEST

"Michael Lotz" <mmlr@xxxxxxxx> wrote:
> .../add-ons/media/codecs/3ivx.codec
> .../add-ons/media/codecs/musepack.codec
> .../add-ons/media/containers/avi.container
> .../add-ons/media/containers/mpeg.container
> .../add-ons/media/containers/musepack.container <- symlink to ../
> codecs
> /musepack.codec

How about putting aside the symlinks, and make "codecs" and 
"containers" the same thing internally? Then each codec/container 
writer could decide for himself where to put it (ie. where it better 
fits semantically).


Other related posts: