[haiku-development] Re: "media-plugin" naming convention (wasRe: Donating codes: APE reader)

  • From: Fredrik Ekdahl <fekdahl@xxxxxxxxx>
  • To: haiku-development@xxxxxxxxxxxxx
  • Date: Thu, 05 Jun 2008 20:07:43 +0200

Stephan Assmus skrev:
+1. I am all for using common names. Demuxer and Muxer is also commonly used, but Container is better. And Codecs fits nicely. I don't know if I like the symlink thing so much, though. It could even work to do something like this:

.../add-ons/media/dormant.media_addon
.../add-ons/media/codecs/3ivx.codec
.../add-ons/media/codecs/avi.container
.../add-ons/media/codecs/mpeg.container
.../add-ons/media/codecs/musepack
.../add-ons/media/codecs/x264.encoder
.../add-ons/media/codecs/xvid.decoder

and simply have containers in codecs too.


Since you are using such descriptive suffices to the files, why have a directory called codecs (or whatever) at all? It feels kinda redundant. Or is that necessary for separating when loading media add-ons and plugins perhaps? Having container add-ons in a dir called codecs doesn't sound logical to me. The cases when you have both format and codec support in a single add-on is probably when the format is so simple that it only supports one kind of codec, and is therefore not really a true "container".

What about
.../add-ons/media/dormant.media_addon
.../add-ons/media/formats/avformat
.../add-ons/media/formats/avi
.../add-ons/media/formats/mpeg
.../add-ons/media/codecs/avcodec
.../add-ons/media/codecs/musepack
.../add-ons/media/codecs/x264
.../add-ons/media/codecs/xvid

Or
.../add-ons/media/dormant.media_addon
.../add-ons/media/avformat.format
.../add-ons/media/avi.format
.../add-ons/media/mpeg.format
.../add-ons/media/avcodec.codec
.../add-ons/media/musepack.decoder
.../add-ons/media/x264.encoder
.../add-ons/media/xvid.encoder

or as an option replace format/-s above with container/-s
?

/Fredrik Ekdahl

Other related posts: