[haiku-development] Re: "media-plugin" naming convention (wasRe: Donating codes: APE reader)

  • From: "Michael Lotz" <mmlr@xxxxxxxx>
  • To: haiku-development@xxxxxxxxxxxxx
  • Date: Thu, 05 Jun 2008 18:18:23 +0200

> > The latter - while it's not strictly necessary to have encoder/
> > decoder
> > in the same file, you will often either use the same library or 
> > even
> > have the reader/decoder in a single file when the container isn't
> > separated from the codec (for example musepack), so I think it's
> > practical to allow them to be in a single file.
> Well. "plugins" is fine enough, let's keep it! ;-)

If it's just about renaming "plugins" because "plugins" sounds so alien 
on BeOS/Haiku I would simply rename it to "codecs" instead. That should 
describe the purpose better than plugins and is a more generally 
understood term. Pure readers/writers that only handle container 
formats could otherwise also be put into a "containers" directory while 
such that combine both reader/writer and decoders/encoders would simply 
be put into "codecs" (and maybe symlink them to "containers" wouldn't 
be that bad of an idea either).

So I could imagine something like:

.../add-ons/media/containers/musepack.container <- symlink to ../codecs

But since I'm not really that familiar in how these media add-ons work 
internally I wouldn't know if this makes sense.


Other related posts: