<philippe.houdoin@xxxxxxx> wrote: > > 3. keep the current structure, but rename "plugins" to something > > like > > "file", "stream", ... - again, I would prefer "file" here for the > > above > > reason. > What about split our "plugins" to the previous "decoders", > "encoders", "extractors" > and "writers" subfolders, indeed? File/stream Haiku's media plugins > are extractors/writers, > after all, no? > Or the issue is now the same file/stream "plugin" feature both read > and write, and can't > anymore be separate? The latter - while it's not strictly necessary to have encoder/decoder in the same file, you will often either use the same library or even have the reader/decoder in a single file when the container isn't separated from the codec (for example musepack), so I think it's practical to allow them to be in a single file. Bye, Axel.