[haiku-development] Re: Usage change proposal for queue_isochronous( ..., startingFrameNumber, .... )

  • From: Siarzhuk Zharski <zharik@xxxxxx>
  • To: haiku-development@xxxxxxxxxxxxx
  • Date: Tue, 16 Jul 2013 13:45:28 +0200

Hi Paul,

Paul Davey писал 16.07.2013 12:13:
On Tue, Jul 16, 2013 at 7:28 PM, Siarzhuk Zharski <zharik@xxxxxx> wrote:
uint32 frame = 0;
queue_isochronous(..., &frame, USB_IO_ASAP, ....);

while (...) {
  queue_isochronous(..., &frame, 0, ....);
}

I am not really well versed with the USB kit or the kernel, but I
would suggest that from your description the parameter be named more
like nextFrameNumber or something.

From the queue_isochronous' point of view it is the starting frame for allocation of the next set of data packets. It is just advanced by queue_isochronous to the first frame number after the end of the last allocated data packet. So the "start" semantic is less obfuscating than the "next" one, IMHO. We are using v3 of USB bus manager module interface that declares this parameter as "startingFrameNumber" so we have to follow original specification. As in case of set_pipe_policy call that is relict of v2 rle-based isochronous interface and has no effect in v3.

--
Kind Regards,
   S.Zharski

Other related posts: