[haiku-development] Re: Questions from Haiku novice

  • From: Markku Hyppönen <make.hypponen@xxxxxxxxxx>
  • To: haiku-development@xxxxxxxxxxxxx
  • Date: Sun, 18 Apr 2010 13:19:16 +0300

Stephan Assmus wrote:
On 2010-04-18 at 00:42:26 [+0200], PulkoMandy<pulkomandy@xxxxxxxxx>  wrote:
Le Sun, 18 Apr 2010 00:16:40 +0200, Markku Hyppönen
<make.hypponen@xxxxxxxxxx>  a écrit:

When I tried same with 'Backrounds' application it didn't find
liblocale.so library. I managed to fix that by changing LIBRARY_PATH but
I couldn't find libicu-common.so.4.2 anywhere (see error below).
I guess this is not the right way to do it  so what would be the best
way to test my changes?
You are running the alpha1 release, right ?
The simplest way is to install a newer nigthly build as the locale stuff
was added after the alpha1 release. Alpha2 should be out soon now, so you
can wait for it.

For testing purpose, you can have a "lib" folder alongside the executable
you want to test and throw in the needed libraries there.

This is correct, but the libbe.so<->  app_server interface was changed
since the alpha 1 release, so when you end up copying the new libbe.so
alongside your generated binary, then you are in for some trouble :-). I
think the easiest would really be upgrade your installation with a nightly.

Best regards,
-Stephan

Yes, that's what I'm going to do.

Thanks to you also

Br,
Markku

Other related posts: