[haiku-development] Re: HiDPI strategies, current and future

  • From: "Mr. waddlesplash" <waddlesplash@xxxxxxxxx>
  • To: haiku-development@xxxxxxxxxxxxx
  • Date: Mon, 30 Aug 2021 20:23:43 -0400

While we are discussing font-related things: does anyone have or know
a good reason why "void BView::GetFont(BFont* font)" should not just
become "BFont BView::Font()"? Perhaps there was some strange compiler
limitation on BeOS that led the engineers to declare the function that
way, but we have no such limitations, and especially if we are going
to be passing the View's Font around more following this proposal, it
would seem to make sense to make this change.

-waddlesplash

Other related posts: