[haiku-development] Re: BGroupLayout documentation inconsisency

  • From: Ingo Weinhold <ingo_weinhold@xxxxxx>
  • To: haiku-development@xxxxxxxxxxxxx
  • Date: Sat, 21 May 2011 13:20:09 +0200

On 2011-05-20 at 21:09:36 [+0200], John Scipione <jscipione@xxxxxxxxx> wrote:
> From Ingo:
> > Alternatively we could introduce a BOrientation typedef and use that
> instead.
> > And eventually rename the enum when we break binary compatibility.
> 
> I don't like this suggestion because the convention to use lowercase enum
> names with no B prefix is by no means limited to the orientation enum. It is
> used by alert_type and button_spacing enums just to name just a few.

Yep, and the intention is to change them all eventually.

> Refactoring the Interface Kit is glass elevator territory and I don't want
> to get into that ball of wax right now.

No refactoring, just providing alternative typedefs and using those instead.

> <aside>While on the topic of enum names, how come resizingMode is defined to
> use an int32 and not a resizing_mode enum in InterfaceDefs.h? Same for flags
> and probably a bunch of others.</aside>

If you mean the individual resizing modes, they could be in an anonymous 
enum. If you mean the parameter type itself, that doesn't work so well with 
flag like things, since the arithmetic OR (|) of two enum members would yield 
an int instead and thus not be compatible with the parameter type.

CU, Ingo

Other related posts: