[haiku-development] Re: BGroupLayout documentation inconsisency

  • From: John Scipione <jscipione@xxxxxxxxx>
  • To: haiku-development@xxxxxxxxxxxxx
  • Date: Fri, 20 May 2011 15:09:36 -0400

From Ryan Leavengood:

> To paraphrase Stephan, "orientation direction" would be pretty lame.
> Maybe for instances like this we could use "orientation _orientation"?

I like this suggestion to get around the apparent lameness of direction
while getting around the lameness of C++.

> Or Doxygen should be fixed to properly parse C++. This particular case
> doesn't seem that tough.

The code is valid C++. doxygen parses it incorrectly -- there is a bug in
doxygen, it should be fixed. I think we can all agree on that. I have
already modified doxygen to fit my needs a bit so I can see if I can make
this change and submit it to that project.

From Ingo:
> Alternatively we could introduce a BOrientation typedef and use that
instead.
> And eventually rename the enum when we break binary compatibility.

I don't like this suggestion because the convention to use lowercase enum
names with no B prefix is by no means limited to the orientation enum. It is
used by alert_type and button_spacing enums just to name just a few.
Refactoring the Interface Kit is glass elevator territory and I don't want
to get into that ball of wax right now.

<aside>While on the topic of enum names, how come resizingMode is defined to
use an int32 and not a resizing_mode enum in InterfaceDefs.h? Same for flags
and probably a bunch of others.</aside>

From Niels Sascha Reedijk:

You should try to alter the parameter name in the .dox file. I think
> it will override the real parameter name.


No this won't work because the dox file is already modified from the code
(See my original post) and apparently doxygen is "smart" enough to detect
that difference and get the definition from the source instead.


John Scipione

Other related posts: