[haiku-development] Re: BGroupLayout documentation inconsisency

  • From: "Ingo Weinhold" <ingo_weinhold@xxxxxx>
  • To: haiku-development@xxxxxxxxxxxxx
  • Date: Fri, 20 May 2011 18:55:54 +0200

On Fri, 20 May 2011 12:44:57 -0400 Ryan Leavengood <leavengood@xxxxxxxxx> wrote:
> On Fri, May 20, 2011 at 12:22 PM, John Scipione <jscipione@xxxxxxxxx>
> wrote:
> >
> > A grep of the src/kits/interface/ directory shows a number of other
> places
> > that repeated orientation variable this is used. 'direction' seems like
> a
> > good variable name to me.
> To paraphrase Stephan, "orientation direction" would be pretty lame.
> Maybe for instances like this we could use "orientation _orientation"?

Alternatively we could introduce a BOrientation typedef and use that instead. 
And eventually rename the enum when we break binary compatibility.

> Or Doxygen should be fixed to properly parse C++. This particular case
> doesn't seem that tough.

At least it's a basic identifier scoping rule (a local identifier hiding a 
global one). It's not that unusual either.

CU, Ingo

Other related posts: