[haiku-development] Re: BGroupLayout documentation inconsisency

  • From: John Scipione <jscipione@xxxxxxxxx>
  • To: haiku-development@xxxxxxxxxxxxx
  • Date: Fri, 20 May 2011 12:22:20 -0400

On Fri, May 20, 2011 at 11:32 AM, Rene Gollent <anevilyak@xxxxxxxxx> wrote:

> On Fri, May 20, 2011 at 11:04 AM, John Scipione <jscipione@xxxxxxxxx>
> wrote:
> > Can someone with a working knowledge of the Layout Kit (Ingo?) please
> > respond on this.
> It's correct, because the first orientation names the enum type (c.f.
> http://dev.haiku-os.org/browser/haiku/trunk/headers/os/interface/InterfaceDefs.h#L185
> ), while the second names the variable itself.

Thank you all for the quick reply.

So this valid C++ to use the same parameter name as the name of the type and
therefore this is a doxygen bug that it is not able to interpret this
correctly. It would be nice if someone could rename the variable name in the
parameter like this though:

BGroupLayout::BGroupLayout(orientation direction, float spacing)

A grep of the src/kits/interface/ directory shows a number of other places
that repeated orientation variable this is used. 'direction' seems like a
good variable name to me. And this is the Layout Kit so we are allowed to
break stuff -- it says so right in the docs. :)

John Scipione

Other related posts: