[haiku-commits] Re: r41125 - haiku/trunk/src/add-ons/media/media-add-ons/usb_webcam/addons/uvc

  • From: Ingo Weinhold <ingo_weinhold@xxxxxx>
  • To: haiku-commits@xxxxxxxxxxxxx
  • Date: Mon, 28 Mar 2011 12:40:16 +0200

On 2011-03-27 at 19:56:30 [+0200], Stephan Aßmus <superstippi@xxxxxx> wrote:
> On 27.03.2011 17:21, korli@xxxxxxxxxxxxxxxx wrote:
> > +struct usbvc_probecommit {
> > +    uint16    hint;
> > +    uint8    formatIndex;
> > +    uint8    frameIndex;
> > +    uint32    frameInterval;
> > +    uint16    keyFrameRate;
> > +    uint16    pFrameRate;
> > +    uint16    compQuality;
> > +    uint16    compWindowSize;
> > +    uint16    delay;
> > +    uint32    maxVideoFrameSize;
> > +    uint32    maxPayloadTransferSize;
> > +    uint32    clockFrequency;
> > +    uint8    framingInfo;
> > +    uint8    preferredVersion;
> > +    uint8    minVersion;
> > +    uint8    maxVersion;
> > +    void    SetFrameInterval(uint32 interval)
> > +        { frameInterval = interval; }
> > +} _PACKED;
> 
> BTW, I think we should stop following this naming style for structs and
> use the same pattern we uses for classes. The same goes for enums. What
> do others think, should we put this in the coding style?

+1

CU, Ingo

Other related posts: