[haiku-commits] Re: r41103 - in haiku/trunk: build/jam data/catalogs/apps/3dmov data/catalogs/apps/aboutsystem data/catalogs/apps/activitymonitor data/catalogs/apps/bootmanager ...

  • From: Stephan Aßmus <superstippi@xxxxxx>
  • To: haiku-commits@xxxxxxxxxxxxx
  • Date: Sat, 26 Mar 2011 19:54:52 +0100

Am 26.03.2011 14:43, schrieb Jonas Sundström:

On 2011-03-26 at 08:52:37 [+0100], Stephan Aßmus<superstippi@xxxxxx>  wrote:
Am 26.03.2011 09:49, schrieb Axel Dörfler:
jonas@xxxxxxxxxxx wrote:
Use resource definition files instead of DoCatalogs rule. Rename
B_TRANSLATE_APP_NAME and related macros to the more generic
B_TRANSLATE_SYSTEM_NAME, to also fits add-ons, folders, etc, and
make 'System name' its standard context.

I don't really understand why you renamed it this way - while it does
indeed fit better for folders and such, *SYSTEM* is a rather bad name
for this, at least as I understood it, this mechanism could well be
used by third party applications as well.
And if not, it should probably not end up in a public header.

It signifies system-wide rather than system-priviledged. Seeing third party
apps as being part of this system, even though they are not part of the

Personally I would have no problem to follow this reasoning and keep the current name.

But I definitely see your point, and I don't mind changing it.

How about just B_TRANSLATE_NAME?

attribute "SYS:NAME"
context "System name"  (what translators see on HTA)
.rdef rule "app_name_catalog_entry"

How about:
attribute "SYS:NAME"
The "SYS:" part being analogous to "BEOS:" in BEOS:TYPE and BEOS:APP_SIG
which are used by third party apps and user documents.

context "Name"
.rdef rule "name_catalog_entry"

Sounds fine to me as well, but I am not into the subject enough to see why it might be a bad idea... :-)

Best regards,

Other related posts: