[haiku-commits] Re: r40849 - haiku/trunk/src/apps/deskbar

  • From: Ingo Weinhold <ingo_weinhold@xxxxxx>
  • To: haiku-commits@xxxxxxxxxxxxx
  • Date: Mon, 07 Mar 2011 10:41:06 +0100

On 2011-03-07 at 10:02:46 [+0100], John Scipione <jscipione@xxxxxxxxx> 
wrote:
> On Mar 6, 2011, at 12:27 PM, "Axel Dörfler" <axeld@xxxxxxxxxxxxxxxx>
> wrote:
> 
> > fredrik.holmqvist@xxxxxxxxx wrote:
> >> -    virtual    bool            QuitRequested();
> > [...]
> >> +    virtual bool            QuitRequested();
> >
> > BTW the tab here is absolutely correct, and doesn't need to be
> > changed.
> > It doesn't hurt to have a space here either, though, so just take this
> > as an invitation to not spend any effort on this in the future :-)

> Why would you have a tab that is one space wide?

Why not?

> Just use a space it
> is cleaner.

Huh?

> Especially if you rename the variable the spaces make
> things easier.

Which variable?

> Either way it is a preference.

Using a tab is more consistent as it also works for shorter keywords 
("static") and makes removing the "virtual" easier, since you don't have to 
change the space to a tab.

CU, Ingo

Other related posts: