[haiku-commits] Re: r40770 - haiku/trunk/src/tests/kits/net/preflet/InterfacesAddOn

  • From: Stephan Aßmus <superstippi@xxxxxx>
  • To: haiku-commits@xxxxxxxxxxxxx
  • Date: Wed, 02 Mar 2011 08:34:03 +0100

On 02.03.2011 01:51, Ryan Leavengood wrote:
On Tue, Mar 1, 2011 at 5:21 PM,<kallisti5@xxxxxxxxxxx>  wrote:

+       static  const uint32        kMsgInterfaceSel = 'ifce';
+       static  const uint32        kMsgInterfaceAct = 'ifac';
+       static  const uint32        kMsgInterfaceCfg = 'ifcf';
+       static  const uint32        kMsgInterfaceTog = 'onof';

Please just go ahead and use the full words. The names are already
long so it really doesn't help much to drop 3 or 4 letters. You must
try to retrain yourself to stop using those shortened words.

Also I don't think this style of kMsgInterfaceFoo is all that nice.
Why not make the constants be clear to their purpose? So I would
suggest:

        static  const uint32        kMsgInterfaceSelected = 'ifsl';
        static  const uint32        kMsgInterfaceClicked = 'ifck'; //
or kMsgInterfaceInvoked
        static  const uint32        kMsgConfigureInterface = 'ifcf';
        static  const uint32        kMsgToggleEnabled = 'onof';

Sorry for writing a reply before reading all my mail. And I like your naming suggestions better, too. Except for maybe kMsgInterfaceClicked, since the meaning is actually a double-click, so kMsgInterfaceInvoked.

Best regards,
-Stephan


Other related posts: