[haiku-commits] Re: r35782 - in haiku/trunk: headers/os/app headers/private/app src/kits/app src/servers/app src/servers/app/drawing

  • From: Stephan Assmus <superstippi@xxxxxx>
  • To: haiku-commits@xxxxxxxxxxxxx
  • Date: Mon, 08 Mar 2010 21:28:34 +0100

On 2010-03-08 at 20:20:32 [+0100], Ryan Leavengood <leavengood@xxxxxxxxx> 
wrote:
> On Sun, Mar 7, 2010 at 6:12 PM,  <superstippi@xxxxxx> wrote:
> > Author: stippi
> >
> >  * Added BCursorID enumeration in App Kit's Cursor.h and new constructor 
> >  which
> >   takes such an id.
> >  * Reused the existing mechanism to to have hardcoded tokens for the 
> >  system
> >   cursors, i.e. removed cursor_which enumeration from ServerProtocol.h and
> >   used BCursorID where cursor_which was previously used.
> 
> Why did you use BCursorID instead of keeping cursor_which?

Because we should fade out these names which pollute the global namespace. 
Everything should be B prefixed. Additionally, I don't see why there should 
be a different naming scheme for classes versus enums versus structs or 
anything else. These are all just types. Once we break binary compatibility, 
personally I would rename all that cruft. Other class frameworks like Qt do 
just fine with the scheme I proposed above. I believe other Haiku developers 
like Ingo and Axel have already adopted the same strategy, but I am not 100% 
sure on that. If others think we should stick with what Be provided, it would 
be worth discussion of course.

> > I hope I will not get too much beating for this one... :-) I know the new
> > default cursor is slightly larger, but I believe the old one was just too 
> > small.
> > Also I noticed that the cursor may be slightly too dark, at least the old 
> > one
> > seems noticeably brighter when compared side by side (the new one has a 
> > slight
> > gradient). That is something I may correct at least. Otherwise I hope 
> > nothing
> > is broken, I've tested in QEMU and so far everything works as intended.
> 
> I like the bigger size and the color and brightness seems fine to me.
> But to my eye the thumb seems a bit too big on the default pointer
> cursor, such that it looks more like a pinching cursor and not a
> pointing one.

Ok. Initially, the cursor was the same size and exact shape as the original 
BeOS one. Then I scaled it up slightly, since I wanted the bigger size, and 
tweaked the pixel alignment. That last bit may have introduced some 
distortions. Hopefully I can bring myself to revisit this, since otherwise 
such things tend to fall off the mental TODO list. I guess continuous 
pestering me will eventually help as well. :-)

> Also it would be nice if there was an easy way to view all the
> cursors. I'm thinking of creating a simple application with just
> single window with a BMenuField to select the cursor which sets the
> cursor for the app to what is selected. Feel free to implement that
> yourself if you want and if I don't do it within the next few days.

The cursors are all done in Icon-O-Matic and checked into the repository. 
Just open them each one in IOM and save it again, it will write the cursor as 
icon of the file. Then look at the folder in 32x32 icon mode.

As for your testing app, it would be much easier to code a matrix of BViews 
that each use another one of the cursors as view cursor 
(BView::SetViewCursor(), works most reliably in MouseMoved()).

> Also with this change you've addressed this enhancement ticket:
> 
> http://dev.haiku-os.org/ticket/3420
> 
> I've given you ownership and marked it fixed.

Thanks!

Best regards,
-Stephan


Other related posts: