[haiku-commits] Re: haiku: hrev52159 - src/servers/app/font docs/interface_guidelines src/kits/network/libnetapi src/servers/app

  • From: looncraz <looncraz@xxxxxxxxxxxx>
  • To: haiku-commits@xxxxxxxxxxxxx
  • Date: Sat, 4 Aug 2018 18:59:44 -0500

On 8/4/2018 15:58, Axel Dörfler wrote:

Am 03/08/2018 um 18:00 schrieb looncraz:
On 8/3/2018 03:21, Philippe Houdoin wrote:
Yeah, forgot my IsPlainFixed() suggestion, IsMonospaced() is a way better name.
If we go with IsMonospaced(), then any reference to the FullAndHalf should be changed to Duospaced, since that's the correct paired term.

Not a fan: we already have a method for this (IsFullAndHalfFixed()). Why introduce another?
Also, "monospaced" is a relatively known term, and full-half is more exact and descriptive.


Full-half makes no sense in English, it's a contradiction in terms.

The proper term is Duospaced.

We would only be changing the name of IsFullAndHalfFixed().

The constants using B_FULL_AND_HALF or whatever need to be B_DUOSPACED or whatever.

My reasoning is quite simple: If you do a Google search for Douspaced, you get logical results pertaining to the problem at hand, including the WikiPedia article entitled "Duospaced font." (https://en.wikipedia.org/wiki/Duospaced_font)

If you search for "full and half font" the results, in order:

star-half | Font Awesome
battery-half | Font Awesome
Vaporware Text Generator...
How to use Font Awesome Star-half-full Icon - w3resource
...

I'm a big fan of using the proper, established, industry terminology whenever it is logical and makes sense.

--The loon

Other related posts: