[haiku-commits] Re: haiku: hrev47853 - src/kits/storage/disk_device headers/private/storage

  • From: Jessica Hamilton <jessica.l.hamilton@xxxxxxxxx>
  • To: haiku-commits@xxxxxxxxxxxxx
  • Date: Sat, 13 Sep 2014 08:34:35 +1200

On 12 September 2014 18:37, Axel Dörfler <axeld@xxxxxxxxxxxxxxxx> wrote:
> Am 12.09.2014 08:09, schrieb jessica.l.hamilton@xxxxxxxxx:
>>
>> 8bfb30c: BPartition: Move dev_t return value to an optional parameter
>
>
> Why? What was wrong with it before?
> Also, we don't use "Pointer" in a name for pointer variables (fortunately,
> we don't use Hungarian notation).

Before it was mixing status_t & dev_t in the same return value. Don't
we normally prefer out arguments to a function that returns a
status_t?

Other related posts: