[haiku-commits] Re: haiku: hrev47012 - src/apps/haiku-depot

  • From: Ingo Weinhold <ingo_weinhold@xxxxxx>
  • To: haiku-commits@xxxxxxxxxxxxx
  • Date: Sun, 16 Mar 2014 13:03:01 +0100

On 03/15/2014 08:03 PM, Jonathan Schleifer wrote:
Btw, while we're at it: I have a problem with the naming scheme gcc2/gcc4. Couldn't we call it 
"Compatibility ABI" and "Current ABI" or something like that? There's a lot of 
checks where the GCC version is checked - which feels really wrong when you want to use Clang.

I believe the naming scheme is visible to the user only wrt. the image names (though the official "gcc2hybrid" doesn't actually mention gcc 4). The architecture names are "x86_gcc2" and "x86".

As for the naming in the developer domain (CPP macros and build system), I wouldn't mind renaming, but it would be quite a bit of work. And it isn't like clang introduced a new ABI, anyway. It just uses the one gcc 4 used already.

Moreover, "Current ABI" isn't a particular good name (it should be an alias at best). I believe a widely used name for the ABI is "Itanium ABI", which isn't really any better wrt. obviousness.

CU, Ingo

Other related posts: