[haiku-commits] Re: haiku: hrev46694 - in src/add-ons: kernel/drivers/graphics/intel_extreme accelerants/intel_extreme

  • From: John Scipione <jscipione@xxxxxxxxx>
  • To: "haiku-commits@xxxxxxxxxxxxx" <haiku-commits@xxxxxxxxxxxxx>
  • Date: Fri, 17 Jan 2014 15:37:40 -0500

On Fri, Jan 17, 2014 at 3:30 PM, Ingo Weinhold <ingo_weinhold@xxxxxx> wrote:
> On 01/17/2014 07:39 PM, John Scipione wrote:
>> On Fri, Jan 17, 2014 at 12:00 PM, Axel Dörfler <axeld@xxxxxxxxxxxxxxxx> 
>> wrote:
>>> Am 17/01/2014 14:49, schrieb pulkomandy@xxxxxxxxxxxxx:
>>>> +static struct display_mode_hook {
>>>> +       bool active;
>>>> +       display_mode *dm;
>>>> +       struct {
>>>> +               uint16 width;
>>>> +               uint16 height;
>>>> +               uint16 space;
>>>> +       } mode;
>>>> +} display_mode_hook;
>>>
>>> Should be called sDisplayModeHook instead
>>
>> I don't think that's true. I'm looking in the coding guidelines for
>> confirmation and I can't find anything about this. Judging from
>> examples in the source code C struct's follow the
>> all_lowercase_underscore_variable_name_convention.
>
> Axel was referring to the variable, not the type. There's probably not even
> a reason to name the type in the first place.

Ah yes, my apologies.

Other related posts: