[openbeos-cdt] Re: .pkg installer user interface

  • From: "Waldemar Kornewald" <wkornewald@xxxxxxxxxxxx>
  • To: openbeos-cdt@xxxxxxxxxxxxx
  • Date: Mon, 16 Apr 2007 12:19:10 +0200


On 4/16/07, Łukasz 'Sil2100' Zemczak <sil2100@xxxxxxxxxxxxx> wrote:
The issue of a PackageBuilder doesn't seem yet to be decided, since in
this field I also have some doubts. I don't think there's an official
decision about the Haiku package system and a PackageBuilder might give
some users the wrong idea. This, of course, might be my personal phobia,
but I hope you get my point.

I agree with you. Haiku packages should, for now, be simple .zip
files. R2 will introduce a real package system.

Anyway, a PackageInspector is a must, then. The form in which it should
be included in the system will yet be decided. There's also the issue of
a PackageUninstaller. Even though it's not quite an issue of usability,
I thought about replacing the .db format of SoftwareWallet and install
package specific information in the config/settings/packages directory.
This might be worth discussing on the main list.

Since we won't have something like SoftwareValet I see no need to
support the legacy DB format. Just do whatever is easier and doesn't
fill the home folder with log files (they should probably go into that
packages folder).

I will gather all our decisions till now and sketch a final UI
proposition. After possible minor changes, this issue would be finally
closed ;) Thanks for all your remarks! It seems I still need to get more
experience in the field of usability.

Cool. Now, that was a fast usability discussion, wasn't it? :)
Regarding usability experience: it's a topic full of controversy and
usability experts often disagree about the details. It depends on
which philosophy you want to follow (explore vs
just-works,don't-care). I think your suggested UI fixed the greatest
flaw (the files pop-up) and that's really what counts the most. The
rest was mostly a question of design philosophy (IMHO, "explore" is
better for games, not apps).

> "Begin" is basically like "OK" and I think more obvious labels should
> be used. What do you think about renaming "Begin" to "Install"?

This seems a good idea. Although the old approach is still quite good,
since we decided already that the window tab should include "Install:
Package name". With this addition, "Begin" also sounds fair, since the
user knows that pressing the button will "begin the installation of
Package name".

I just like to have it explicit and I think it would be more
consistent with our HIG (which says to use explicit actions instead of
"OK", etc. which depend on the context).

Waldemar Kornewald

Other related posts: