[haiku-bugs] Re: [Haiku] #8454: Very low network performance with a Marvell Yukon card.

  • From: "korli" <trac@xxxxxxxxxxxx>
  • Date: Tue, 10 Apr 2012 15:16:15 -0000

#8454: Very low network performance with a Marvell Yukon card.
---------------------------------------------+----------------------------
   Reporter:  bga                            |      Owner:  nobody
       Type:  bug                            |     Status:  new
   Priority:  high                           |  Milestone:  R1
  Component:  Drivers/Network/marvell_yukon  |    Version:  R1/Development
 Resolution:                                 |   Keywords:
 Blocked By:                                 |   Blocking:
Has a Patch:  0                              |   Platform:  All
---------------------------------------------+----------------------------

Comment (by korli):

 Replying to [comment:4 umccullough]:
 > Did the problem start around hrev43744?
 >
 > After running a fresh coverity scan, it seems it has detected a bad
 conditional check in the new HAIKU_CHECK_DISABLE_INTERRUPTS() code:
 >
 > {{{
 > if (status == 0 || status == 0xffffffff ||
 > }}}
 >
 > Where status is apparently a uint16, so the second condition will always
 be false.
 >
 > It's CID 11358 if anyone is interested in checking on it.

 Looking again at the code, it should be: uint32_t status;

-- 
Ticket URL: <http://dev.haiku-os.org/ticket/8454#comment:5>
Haiku <http://dev.haiku-os.org>
Haiku - the operating system.

Other related posts: